summaryrefslogtreecommitdiff
path: root/dev-python/pygresql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
commitd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (patch)
tree2a3ee43f080d1d0086964de8c29ccf1021fdfda7 /dev-python/pygresql
parentea31ad0ed5501d0bf92267c35beaf06ac016bad2 (diff)
gentoo resync : 15.05.2018
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest2
-rw-r--r--dev-python/pygresql/pygresql-4.1.1-r2.ebuild75
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index 7c342509c00a..1c24d1e147b5 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1,5 +1,3 @@
-DIST PyGreSQL-4.1.1.tgz 100883 BLAKE2B 8b3876803b61fde62a248cf6499b9396a16069fd5cebad8f17ca942990a5502a702081b395745863d54b304d426455dd94d816caea9e09809a7ff0ca1b4903b0 SHA512 4b37c56f2112471aa5f3003a1d867382ce1b7510afa0963f0ceeb2f8175ca601bb5bade9ea2038d44a1041f12233e364f138a635bb7b353d0a82aeb7d9d49b7f
DIST PyGreSQL-5.0.4.tar.gz 637569 BLAKE2B 3f7bddb8b5e455ca4f181d254d4d125b89a64d7aaa1440b9ab5d916c395b9d93fc9814269992c134b6fd8a81f436752dbe4d7c06125e683a5257361d428c6a6f SHA512 f177ca3b023c007dafe80369b86a1742ff334137e493c3c19ac8bda0181d2543cd2431b8ab8d2d43f30d681121324bc4f236a9ebbddf1e927b071db7c9b34ea6
-EBUILD pygresql-4.1.1-r2.ebuild 1592 BLAKE2B cf71efda28ab0c4cd24540307c5b68d8585cc06ce92b415b399d4a2ce4bc70d2a9a2a4293061e75a3c3e061b37ae0d56165010ae7b048bf2512de46981ab87f4 SHA512 c862f696772b9b8d6242fc98721d8b1e7e608f3a54ddc2bd4b34e24e782390cb1ac8e4060ab13ae025b9d8c229d4b9bb03cc2a6facb254ec49073477cbe32c2d
EBUILD pygresql-5.0.4.ebuild 718 BLAKE2B 9d1729500f651809825cf91647736bd9c6fc096f77755fe5400200adafb9325699be202dc0144cfbc45a573c1c4dfbd75384a16334463ddb1de0e9168bf1c134 SHA512 61c8ccd1da12803cebaf112b453d414df85e035ebee4d909ab3deecd8402df206a11361a22badf9a5d752503e37faa29b5f998ba8c7c60db8b3f918c397410dc
MISC metadata.xml 452 BLAKE2B 8d60fd06e68e39b5d373f30fec25979a0a67c51eee216425e382b559b908ccd12e425c95995dfd28d8487fb306f03fa10d8a71320a4ff5ebd6349e887af624e9 SHA512 f6877e2fd8cb2b6606a29e421d0f0ab4fd66a5e7446a4307718d1c0435c2e8ab3c59db795ca1e18e58eb79d0474c57bf35a3d0544095d2d7d618cf25e96ff55f
diff --git a/dev-python/pygresql/pygresql-4.1.1-r2.ebuild b/dev-python/pygresql/pygresql-4.1.1-r2.ebuild
deleted file mode 100644
index c3b79dd202cd..000000000000
--- a/dev-python/pygresql/pygresql-4.1.1-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-POSTGRES_COMPAT=( 9.{0,1,2,3,4,5} )
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="PyGreSQL-${PV}"
-
-DESCRIPTION="A Python interface for the PostgreSQL database"
-HOMEPAGE="http://www.pygresql.org/"
-SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tgz"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
-IUSE="doc"
-
-DEPEND="|| (
- dev-db/postgresql:9.5
- dev-db/postgresql:9.4
- dev-db/postgresql:9.3
- dev-db/postgresql:9.2
- dev-db/postgresql:9.1
- dev-db/postgresql:9.0
-)"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-# Verify that the currently selected PostgreSQL slot is set to one of
-# the slots defined in POSTGRES_COMPAT.
-postgres_check_slot() {
- if ! declare -p POSTGRES_COMPAT &>/dev/null; then
- die 'POSTGRES_COMPAT not declared.'
- fi
-
-# Don't die because we can't run postgresql-config during pretend.
-[[ "$EBUILD_PHASE" = "pretend" && -z "$(which postgresql-config 2> /dev/null)" ]] \
- && return 0
-
- local res=$(echo ${POSTGRES_COMPAT[@]} \
- | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
-
- if [[ "$res" -eq "0" ]] ; then
- eerror "PostgreSQL slot must be set to one of: "
- eerror " ${POSTGRES_COMPAT[@]}"
- return 1
- fi
-
- return 0
-}
-
-pkg_pretend() {
- postgres_check_slot
-}
-
-pkg_setup() {
- postgres_check_slot || die
-}
-
-python_install_all() {
- local DOCS=( docs/*.txt )
- distutils-r1_python_install_all
-
- if use doc; then
- insinto /usr/share/doc/${PF}/tutorial
- doins tutorial/*
- dohtml docs/*.{html,css}
- fi
-}