summaryrefslogtreecommitdiff
path: root/dev-python/pygresql/pygresql-6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
commit713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (patch)
tree9e9281ff07875c667fb3bf223166de68137f4635 /dev-python/pygresql/pygresql-6.0.ebuild
parent08b4047e14c989cfb931eff95973837f54ccc9e1 (diff)
gentoo auto-resync : 04:10:2023 - 11:51:15
Diffstat (limited to 'dev-python/pygresql/pygresql-6.0.ebuild')
-rw-r--r--dev-python/pygresql/pygresql-6.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pygresql/pygresql-6.0.ebuild b/dev-python/pygresql/pygresql-6.0.ebuild
new file mode 100644
index 000000000000..6ab105e94608
--- /dev/null
+++ b/dev-python/pygresql/pygresql-6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="PyGreSQL"
+POSTGRES_COMPAT=( 9.6 {10..14} )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 postgres pypi
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="
+ https://pygresql.github.io/
+ https://github.com/PyGreSQL/PyGreSQL/
+ https://pypi.org/project/PyGreSQL/
+"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ postgres_pkg_setup
+ fi
+}
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage test || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ rm -rf pg || die
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}