summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.3.1.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.3.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild b/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
deleted file mode 100644
index 174617915ba2..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.3.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="http://pygraphviz.github.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
-RDEPEND="media-gfx/graphviz"
-DEPEND="${RDEPEND}
- dev-lang/swig:0
- test? (
- dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-docs.patch
- "${FILESDIR}"/${P}-swig-3.patch
-)
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- swig -python pygraphviz/graphviz.i || die
-}
-
-python_test() {
- PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
- nosetests -c setup.cfg -x -v || die
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}