summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz/pygraphviz-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pygraphviz/pygraphviz-1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.2.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.2.ebuild b/dev-python/pygraphviz/pygraphviz-1.2.ebuild
new file mode 100644
index 000000000000..25e0035803a5
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ https://pypi.python.org/pypi/pygraphviz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-setup.py.patch
+ "${FILESDIR}"/${P}-avoid_tests.patch
+)
+
+python_test() {
+ PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
+ "${PYTHON}" \
+ -c "import pygraphviz.tests; pygraphviz.tests.run()" \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}