summaryrefslogtreecommitdiff
path: root/dev-python/pygments/pygments-2.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 02:29:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 02:29:20 +0100
commit7896e968620f545121daeea31881814ccc8d4f47 (patch)
tree537e4de8b13e1b2add5e11c9ecf4c7abf68a0a94 /dev-python/pygments/pygments-2.13.0.ebuild
parent7255c5d5fcd8fcdd07d2791563dc43bf4e14cf3a (diff)
gentoo auto-resync : 16:08:2022 - 02:29:20
Diffstat (limited to 'dev-python/pygments/pygments-2.13.0.ebuild')
-rw-r--r--dev-python/pygments/pygments-2.13.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pygments/pygments-2.13.0.ebuild b/dev-python/pygments/pygments-2.13.0.ebuild
new file mode 100644
index 000000000000..c5c990add1f6
--- /dev/null
+++ b/dev-python/pygments/pygments-2.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}