summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-1.13.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
commit51a01b0f2371b8dfc39f2747ecafd7d5f083ecb4 (patch)
tree55d5c62353eb98ea2809ea087e9fc4b215c53563 /dev-python/pygit2/pygit2-1.13.3.ebuild
parent46de1a2f454a1465026d681f5dfe8db7dde5b126 (diff)
gentoo auto-resync : 21:11:2023 - 23:10:38
Diffstat (limited to 'dev-python/pygit2/pygit2-1.13.3.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-1.13.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-1.13.3.ebuild b/dev-python/pygit2/pygit2-1.13.3.ebuild
new file mode 100644
index 000000000000..8e3b0e149b31
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.13.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.7*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.16.0:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}