summaryrefslogtreecommitdiff
path: root/dev-python/pyghmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 00:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 00:48:54 +0000
commitb0b85e141f6a9a74d9d6bdce989a626ff5e92523 (patch)
tree18a9a4fc7bf0724456198e68c0012407c085de02 /dev-python/pyghmi
parent61148529b1734102fa937560847f47719bbd9bd4 (diff)
gentoo auto-resync : 25:03:2023 - 00:48:54
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest2
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.60.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 62265f3bab5f..a8ba1cab3a82 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,3 +1,5 @@
DIST pyghmi-1.5.59.tar.gz 251390 BLAKE2B 0299bf92e6252e21499172e9d4389ecd2a19912ddb9cf9cd8769fc6dd994536526f909711975af58a01169ec2aa20eabba5ca20a5f66ddaaf948be9c1f77060c SHA512 adb64a400a53a17d8837972220807b9bc6f00291316c2f28a45f56d7f9fbaaa8775002e37eeb12e96445636c7a0a25c2829f4ee6c9ffa4c52a83fb35d5391b47
+DIST pyghmi-1.5.60.tar.gz 251748 BLAKE2B 8e860847293db5b747144b3f5e21690c898ebc80c5de8c24dac169b38653893c90b80b0820d3acb5309e95e934cb75e8390b9b5f65e08513a1bd0b62ee62fe9f SHA512 a75528fea803ec68ae12f34befc7d95072baa1bffb8a60d62ebccf41b62f5bdbb510d1b11d9f31ddcc82830ebdc3b31ef6d51b5bca16c89be5dd450cd0a1f82e
EBUILD pyghmi-1.5.59.ebuild 938 BLAKE2B c5d2c394e1426d06f47476ccc20a27794c451a9e7d0e17d58f7bee098f368b5014b3fa44a25069236761d6ab5dddf5be57911c4da84e085738cbf6c905088b95 SHA512 a493c3e88aee99c2cc96462457a2be48c11b59e7de2cca55512f2a8ceb69860bd5e4ef82e58258ceb19c09c3059ff3cb6245a22cb139d0fb076f878d37c40e89
+EBUILD pyghmi-1.5.60.ebuild 938 BLAKE2B c5d2c394e1426d06f47476ccc20a27794c451a9e7d0e17d58f7bee098f368b5014b3fa44a25069236761d6ab5dddf5be57911c4da84e085738cbf6c905088b95 SHA512 a493c3e88aee99c2cc96462457a2be48c11b59e7de2cca55512f2a8ceb69860bd5e4ef82e58258ceb19c09c3059ff3cb6245a22cb139d0fb076f878d37c40e89
MISC metadata.xml 439 BLAKE2B 0c7ccbc424041a506c60bb0934e40465b64a9779d4d2b6992ba5d4c8563b114da1470a1b221798773824b92fc7b5d6e7b2f0b0afff7f266ea1fbf450f336c497 SHA512 0c919c41bbef88b080cd5941d767cb3f79e935dfedb6da16353b80da2966d488936768b8ad04c7fc695b3c6376143430115f5533b3492816bf293ab2ccf37fb8
diff --git a/dev-python/pyghmi/pyghmi-1.5.60.ebuild b/dev-python/pyghmi/pyghmi-1.5.60.ebuild
new file mode 100644
index 000000000000..7b3d2e7d3897
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.60.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest