summaryrefslogtreecommitdiff
path: root/dev-python/pyghmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /dev-python/pyghmi
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest3
-rw-r--r--dev-python/pyghmi/metadata.xml11
-rw-r--r--dev-python/pyghmi/pyghmi-1.0.22.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
new file mode 100644
index 000000000000..39105630c41d
--- /dev/null
+++ b/dev-python/pyghmi/Manifest
@@ -0,0 +1,3 @@
+DIST pyghmi-1.0.22.tar.gz 123267 SHA256 8024931866a0ff68404dc0d38db2b516920f1b0fe68ac67da33647a06f336c7a SHA512 9e3bc6b5f33d5496d7e58d2ea558d20d45a7690d493f2d1ad56fdd5570279a38e8934d8425c3d3207d8001da85a9a0b1319463b802fa9f121db7448aa919bddc WHIRLPOOL 9884a43fa69da4bba156fdf4140c7aebdfcfdaa02cd193da979734544971fd16dca0846f5b896e2f7f65111b6aff1991628a6ca25fc94e3a6b08855add76c407
+EBUILD pyghmi-1.0.22.ebuild 1233 SHA256 5b502d3e10656f9fabbad997a7380a1543d4303230c6a81a0df964bc69b0a354 SHA512 0b61a9855307d0c7c5cb2193893a2353d9dadcf5ba9f0f537fbcb6cb2695fd6655bec19f61cebb6db45b62180703cb7a50b63b51c5bf22687ba8a42466a75a63 WHIRLPOOL 8047556580eb455ba88eb0be32c97810083cf961127b3042ab4947ab74f6463bab6c67dcd073dcc71c339a2b21ab2b864542e054ceaf1a1a151e84260ec89677
+MISC metadata.xml 343 SHA256 4f98430f926ba7782b4109c8905d9cc87badeef40f8dce78b90b36ec0f6f5662 SHA512 cb4c5f58339d6c5f181bb0e9a1aacb4e3c30c5690744e0ee6649e82eece03678246cfe3b13c219e177de8812c6916fe1b6b49443c2dc0a00ed1d024c8858b5c9 WHIRLPOOL b2c88c1a7dade51cb4b69b5e0a0d5af797f7db80e46a0c1bcbe4f2ee6b2b00534e55f9f37ee7c29d5ef507882a89a7c1cb397af07cc5f290e95f02f18871761e
diff --git a/dev-python/pyghmi/metadata.xml b/dev-python/pyghmi/metadata.xml
new file mode 100644
index 000000000000..9ae992913b2b
--- /dev/null
+++ b/dev-python/pyghmi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pyghmi</remote-id>
+ <remote-id type="github">openstack/pyghmi</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyghmi/pyghmi-1.0.22.ebuild b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
new file mode 100644
index 000000000000..3be2b5d11b80
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+#636824 older versions of cli_helpers break the build
+DEPEND="${RDEPEND}
+ !<dev-python/cli_helpers-1.0.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py testr --coverage || die "Tests failed under ${EPYTHON}"
+}