summaryrefslogtreecommitdiff
path: root/dev-python/pyghmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyghmi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest3
-rw-r--r--dev-python/pyghmi/metadata.xml11
-rw-r--r--dev-python/pyghmi/pyghmi-1.0.22.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
new file mode 100644
index 000000000000..71c1b34e6053
--- /dev/null
+++ b/dev-python/pyghmi/Manifest
@@ -0,0 +1,3 @@
+DIST pyghmi-1.0.22.tar.gz 123267 BLAKE2B 8cfa716d04411dc5228d86cf8813ddb4fb61b7bfeb6618f0182fe42c7ed1deb46e876e085a732d69b3c7390c37a8bc62a3bf15313166574ec98ccefa784b97eb SHA512 9e3bc6b5f33d5496d7e58d2ea558d20d45a7690d493f2d1ad56fdd5570279a38e8934d8425c3d3207d8001da85a9a0b1319463b802fa9f121db7448aa919bddc
+EBUILD pyghmi-1.0.22.ebuild 1235 BLAKE2B 5c2e0f5b179c8b66c206c4f0475e57077372848236b279e6768354a5a5ffe2742372aa0ca18fa99b8265d929edc8c9596a3ccc0e4c825fbb405102a64a02f8c6 SHA512 08b057bd0eb1c295d62c5602320ac67d95e90faf14eb400c8e124d6d1d18048239e9c40c2cf5bb6ad9c5282d312167205e6e423117683340e158b06339eb051a
+MISC metadata.xml 343 BLAKE2B 107a20dca0846a5e4dc8d61825da4193cc7525abad94e161022371ccba00523822c69cf0cae23d13b6f650ec11b98ef4640b5cf18437d60a9a5a6bf37867e9e8 SHA512 cb4c5f58339d6c5f181bb0e9a1aacb4e3c30c5690744e0ee6649e82eece03678246cfe3b13c219e177de8812c6916fe1b6b49443c2dc0a00ed1d024c8858b5c9
diff --git a/dev-python/pyghmi/metadata.xml b/dev-python/pyghmi/metadata.xml
new file mode 100644
index 000000000000..9ae992913b2b
--- /dev/null
+++ b/dev-python/pyghmi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pyghmi</remote-id>
+ <remote-id type="github">openstack/pyghmi</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyghmi/pyghmi-1.0.22.ebuild b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
new file mode 100644
index 000000000000..0e91a2991a91
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+#636824 older versions of cli_helpers break the build
+DEPEND="${RDEPEND}
+ !<dev-python/cli_helpers-1.0.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py testr --coverage || die "Tests failed under ${EPYTHON}"
+}