summaryrefslogtreecommitdiff
path: root/dev-python/pyghmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-23 10:47:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-23 10:47:12 +0000
commit02d5de423c2b7f8d7c873bcc7a1a222b1847149d (patch)
tree29d109245f3aa2842c63489c8ec537f85e92ff41 /dev-python/pyghmi
parent0770f5276c9044be774368cba8d9d8ce7a43627a (diff)
gentoo auto-resync : 23:01:2024 - 10:47:12
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest2
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.66.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 148c1f3bd243..6931bfec89b2 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,3 +1,5 @@
DIST pyghmi-1.5.65.tar.gz 256355 BLAKE2B c3e64fd7f39d1fc785cc4b337ff4f5578978b79aeecb6c77d1291a1d54e5bc0b566e88af149b68ded75cac7c4ec9f89401cf8941fe4710514fb8af19bce82faa SHA512 a82db08e93b68633403a19b86dfcb0951065165846d1fd3a4b92e38438cdcb88f9387480f7a5c2d866a0e7d4488d35396de6e5ee73d7ebbdf78055b6390eb708
+DIST pyghmi-1.5.66.tar.gz 256768 BLAKE2B 4be0359fb4a35611867f2aa68f558e94bf2d5402cb4ceb20d966d97d3b758ba8b25d19c438ff4e30b34fe0d0cc369e3803c5ccf71f101ac741587138832ff367 SHA512 87bc0ec1e79241416c87a6eee8a730bb253242f6ef8c64e0fb24f2d443f66682659a3eaceebfdaaa618393c96118c26695ffabec8afc82226136100d569db81d
EBUILD pyghmi-1.5.65.ebuild 946 BLAKE2B 17c03e210d11e2135d0dce7f9af87b0254e89bb5cf7e01f94222aed6dfd5fc08531911a2e70ea6b4e0d3beb5be60d775a315c697b72f5faf7301e62a09f8dd1b SHA512 5527f59f8c4d924e5402c98eafaee60a9527dcc6ce32ea7625ef8d0f0cb77c1f0e3bb78757851b9f873d8670773267bc6764265381cae4960e481df443eb444b
+EBUILD pyghmi-1.5.66.ebuild 946 BLAKE2B 45f0586d760424e272a4e3674d3eda96e8938c67d0242daa8ed08fecb94a507db1b65e5ebc6b8634fd5e2fa01a869ee810333ef5815e050365844a0da8134565 SHA512 e74071f9a8006148ef9d590e03dd008248a007d87155687d2f2ac85afd8e07db4d42fef99740dad9e8df6668e2f0e9055f4601d51a93abbbf809921045f1fdd3
MISC metadata.xml 439 BLAKE2B 0c7ccbc424041a506c60bb0934e40465b64a9779d4d2b6992ba5d4c8563b114da1470a1b221798773824b92fc7b5d6e7b2f0b0afff7f266ea1fbf450f336c497 SHA512 0c919c41bbef88b080cd5941d767cb3f79e935dfedb6da16353b80da2966d488936768b8ad04c7fc695b3c6376143430115f5533b3492816bf293ab2ccf37fb8
diff --git a/dev-python/pyghmi/pyghmi-1.5.66.ebuild b/dev-python/pyghmi/pyghmi-1.5.66.ebuild
new file mode 100644
index 000000000000..f4adcb0eed3b
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.66.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest