summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml/pygccxml-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-20 17:13:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-20 17:13:51 +0000
commitbe675f929577458bd306c90ed78b62054197c0b1 (patch)
tree5eabf108becbac5f9628fb677b1a0eb93fab07a3 /dev-python/pygccxml/pygccxml-2.4.0.ebuild
parentc72af498eade96364bed882cf8ab30fc3da7d772 (diff)
gentoo auto-resync : 20:11:2023 - 17:13:50
Diffstat (limited to 'dev-python/pygccxml/pygccxml-2.4.0.ebuild')
-rw-r--r--dev-python/pygccxml/pygccxml-2.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pygccxml/pygccxml-2.4.0.ebuild b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
new file mode 100644
index 000000000000..7c80f9e6c423
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A specialized XML reader to navigate C++ declarations"
+HOMEPAGE="https://github.com/CastXML/pygccxml"
+SRC_URI="https://github.com/CastXML/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/castxml
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+
+python_prepare_all() {
+ eapply -p0 "${FILESDIR}/${PN}-2.4.0-pyproject.patch"
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}