summaryrefslogtreecommitdiff
path: root/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
new file mode 100644
index 000000000000..2f5df88d3689
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+PYSDL="${PN}-2.1.0"
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image[png,jpeg]
+ >=media-libs/sdl2-mixer-2.0.2
+ media-libs/sdl2-ttf
+ virtual/jpeg:62
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+
+PATCHES=( "${FILESDIR}/pygame_sdl2-6.99.12.4-mixer.patch" )
+
+# PyGame distribution for this version has some pregenerated files;
+# we need to remove them
+python_prepare_all()
+{
+ rm -r "${S}"/gen{,3} || die
+ distutils-r1_python_prepare_all
+}