summaryrefslogtreecommitdiff
path: root/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
deleted file mode 100644
index d66b4262bd04..000000000000
--- a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-inherit distutils-r1
-
-PYSDL="${PN}-2.1.0"
-
-DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
-HOMEPAGE="https://github.com/renpy/pygame_sdl2"
-SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1 ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/libpng:0=
- media-libs/libsdl2:=[video]
- media-libs/sdl2-image:=[png,jpeg]
- media-libs/sdl2-mixer:=
- media-libs/sdl2-ttf:=
- virtual/jpeg:0"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
-
-# PyGame distribution for this version has some pregenerated files;
-# we need to remove them
-python_prepare_all()
-{
- rm -r gen{,3} || die
- distutils-r1_python_prepare_all
-}