summaryrefslogtreecommitdiff
path: root/dev-python/pyfuse3/pyfuse3-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pyfuse3/pyfuse3-3.1.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pyfuse3/pyfuse3-3.1.1.ebuild')
-rw-r--r--dev-python/pyfuse3/pyfuse3-3.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyfuse3/pyfuse3-3.1.1.ebuild b/dev-python/pyfuse3/pyfuse3-3.1.1.ebuild
new file mode 100644
index 000000000000..ae3a573f428a
--- /dev/null
+++ b/dev-python/pyfuse3/pyfuse3-3.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python 3 bindings for libfuse 3 with asynchronous API"
+HOMEPAGE="https://github.com/libfuse/pyfuse3"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/release-${PV}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CDEPEND="
+ sys-fs/fuse:3
+"
+
+RDEPEND="
+ dev-python/trio[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+
+DEPEND="${CDEPEND}"
+
+BDEPEND="test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest