summaryrefslogtreecommitdiff
path: root/dev-python/pyflakes/pyflakes-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-17 00:09:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-17 00:09:46 +0100
commit74e526c590f52d24a213e25f77858ae0b34ec2c8 (patch)
tree0f6f22133ae9cc04958f6df6d39a02d90ffb1aaf /dev-python/pyflakes/pyflakes-3.2.0.ebuild
parent0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (diff)
gentoo auto-resync : 17:06:2024 - 00:09:46
Diffstat (limited to 'dev-python/pyflakes/pyflakes-3.2.0.ebuild')
-rw-r--r--dev-python/pyflakes/pyflakes-3.2.0.ebuild33
1 files changed, 22 insertions, 11 deletions
diff --git a/dev-python/pyflakes/pyflakes-3.2.0.ebuild b/dev-python/pyflakes/pyflakes-3.2.0.ebuild
index cfab4fb36de1..82d5fd5056a3 100644
--- a/dev-python/pyflakes/pyflakes-3.2.0.ebuild
+++ b/dev-python/pyflakes/pyflakes-3.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -22,15 +22,26 @@ distutils_enable_tests pytest
python_test() {
local EPYTEST_DESELECT=()
- if [[ ${EPYTHON} == pypy3 ]]; then
- # regressions with pypy3.10
- # https://github.com/PyCQA/pyflakes/issues/779
- EPYTEST_DESELECT+=(
- pyflakes/test/test_api.py::CheckTests::test_eofSyntaxError
- pyflakes/test/test_api.py::CheckTests::test_misencodedFileUTF8
- pyflakes/test/test_api.py::CheckTests::test_multilineSyntaxError
- )
- fi
-
+ case ${EPYTHON} in
+ pypy3)
+ # regressions with pypy3.10
+ # https://github.com/PyCQA/pyflakes/issues/779
+ EPYTEST_DESELECT+=(
+ pyflakes/test/test_api.py::CheckTests::test_eofSyntaxError
+ pyflakes/test/test_api.py::CheckTests::test_misencodedFileUTF8
+ pyflakes/test/test_api.py::CheckTests::test_multilineSyntaxError
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # failing due to improved error message
+ # https://github.com/PyCQA/pyflakes/issues/812
+ pyflakes/test/test_api.py::IntegrationTests::test_errors_syntax
+ pyflakes/test/test_api.py::TestMain::test_errors_syntax
+ )
+ ;;
+ esac
+
+ local -X PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}