summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs/pyfakefs-4.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pyfakefs/pyfakefs-4.5.6.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-4.5.6.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-4.5.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-4.5.6.ebuild b/dev-python/pyfakefs/pyfakefs-4.5.6.ebuild
new file mode 100644
index 000000000000..bc616b332663
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-4.5.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" -m pyfakefs.tests.all_tests -v ||
+ die "tests failed under ${EPYTHON}"
+}