summaryrefslogtreecommitdiff
path: root/dev-python/pyeclib/pyeclib-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pyeclib/pyeclib-1.6.1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pyeclib/pyeclib-1.6.1.ebuild')
-rw-r--r--dev-python/pyeclib/pyeclib-1.6.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyeclib/pyeclib-1.6.1.ebuild b/dev-python/pyeclib/pyeclib-1.6.1.ebuild
new file mode 100644
index 000000000000..0709af870095
--- /dev/null
+++ b/dev-python/pyeclib/pyeclib-1.6.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
+HOMEPAGE="
+ https://opendev.org/openstack/pyeclib/
+ https://pypi.org/project/pyeclib/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ dev-libs/liberasurecode
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # https://review.opendev.org/c/openstack/pyeclib/+/798010
+ sed -e '/library_dirs/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "jerasure backend" dev-libs/jerasure
+}