summaryrefslogtreecommitdiff
path: root/dev-python/pydotplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pydotplus
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pydotplus')
-rw-r--r--dev-python/pydotplus/Manifest5
-rw-r--r--dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch17
-rw-r--r--dev-python/pydotplus/metadata.xml4
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2.ebuild40
4 files changed, 39 insertions, 27 deletions
diff --git a/dev-python/pydotplus/Manifest b/dev-python/pydotplus/Manifest
index 38c9142f7abc..bc17cc5b5de6 100644
--- a/dev-python/pydotplus/Manifest
+++ b/dev-python/pydotplus/Manifest
@@ -1,3 +1,4 @@
+AUX pydotplus-2.0.2-tests.patch 907 BLAKE2B 387823545ea3b1372b6584a4b2daca756eb21d81487e3749309c155e37b21171e8e624d54caecc0b356a1456446a4e3b8340b5fc233301bc270fb3056571a601 SHA512 21dd557a0a94d6ad0e4932e01a97a450d76c0f7bcceab870b0ba60a2b96c711ab139fc682ca2a20da4c68b49fe37577763639bb77b9fbe28c7fa1281f2e5bb4b
DIST pydotplus-2.0.2.tar.gz 278677 BLAKE2B 879271ba7e2104134a71caef7676082420770dcdb34aeabfe76232ad8f9774d3e90a9f7ca5fb407a7a4e8e0c4e5e01824bd0d5936fe77554cc661839fcc0dc7b SHA512 6f06a1f284401123a4514f9e9a4974dee8dc8d01e6b7c40a797fb70eed22b99fe774272f8b106b5632a33f524b356349fe1ff9633101ff61ef2fc3fe69d641ac
-EBUILD pydotplus-2.0.2.ebuild 933 BLAKE2B 2ace3cd5e39fd96752e866e4c24e1f2df8ba3dba134777630fa98580ea1bc39f26ebbc7d3a6f2133ca975e4b08da2895d847776cd8ec9e6cde0f7b1c56141c81 SHA512 9934ca01585aab07eac01c02b22d133dc29d9fbb2c888396f168f41b439e82d8a15e401594d2383d53985adeceb657f5f432c385745951d223547e7b9ae65280
-MISC metadata.xml 608 BLAKE2B ced35e0b512acddd9ecd1ab4b335bba68fa15e0dfb9d4de8e498d00f4257e029035af24db49c7cb8c932e0626017283088e36b02e463f18abd22cfd4618e7d3f SHA512 385fae41f18094ee1d813eadcc1ee1d9abe75b1b0b713b79fd15a10ecdf31e897cd0a24d6bca58080d4a3404bb0cf17965d449347745789afa74dec7e3b78fb2
+EBUILD pydotplus-2.0.2.ebuild 656 BLAKE2B 3619d05d14fcd707dd15d52c0e46ec6ce61c13de3e76188b085d5169b8bb432e2e5bd6a3481c4ae636b59ce6f1cfce7ace89be54e8b945780c11421424b02a6c SHA512 f8195c8916cd4963124c8b3f3d8fd2cedae02f926e695a2b78d93865fe82de4a8790e8c3f882573ef7b7e5802f06ced6a50d78bad297e4df44347a78f8844d04
+MISC metadata.xml 608 BLAKE2B a3bb72fe1014a3c5a094baff6002a47999c6055d81681b0df29f90d24554cd609b5940b30560d34550ffe3c161a6e76fe05d2a7128a2292f2e8cb4494d7aae30 SHA512 f05b8685f9afe5083512eafb1041f8b868c67b5b97f90f912a13e78717826526c5530af6c11a5e92318f27eab8a875835a66775ff36453fd6f9158dcdeb78a62
diff --git a/dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch b/dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch
new file mode 100644
index 000000000000..65d9c5f9f45b
--- /dev/null
+++ b/dev-python/pydotplus/files/pydotplus-2.0.2-tests.patch
@@ -0,0 +1,17 @@
+--- a/test/pydot_unittest.py
++++ b/test/pydot_unittest.py
+@@ -142,6 +142,7 @@ class TestGraphAPI(unittest.TestCase):
+ self.assertEqual(g2.get_edges()[0].get_source(), node1)
+ self.assertEqual(g2.get_edges()[0].get_destination(), node2)
+
++ @unittest.skip(reason="Known to fail on Gentoo, reported upstream: https://github.com/carlos-jenkins/pydotplus/issues/22")
+ def test_graph_with_shapefiles(self):
+
+ shapefile_dir = os.path.join(TEST_DIR, 'from-past-to-future')
+@@ -225,6 +226,7 @@ class TestGraphAPI(unittest.TestCase):
+ def test_my_regression_tests(self):
+ self._render_and_compare_dot_files(MY_REGRESSION_TESTS_DIR)
+
++ @unittest.skip(reason="Known to fail on Gentoo, reported upstream: https://github.com/carlos-jenkins/pydotplus/issues/22")
+ def test_graphviz_regression_tests(self):
+ self._render_and_compare_dot_files(REGRESSION_TESTS_DIR)
diff --git a/dev-python/pydotplus/metadata.xml b/dev-python/pydotplus/metadata.xml
index 3f0fc2d5c2a5..f90e59377221 100644
--- a/dev-python/pydotplus/metadata.xml
+++ b/dev-python/pydotplus/metadata.xml
@@ -10,8 +10,8 @@
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
- PyDotPlus is an improved version of the old pydot project that provides a Python
- Interface to Graphviz’s Dot language.
+ PyDotPlus is an improved version of the old pydot project that provides
+ a Python Interface to Graphviz’s Dot language.
</longdescription>
<upstream>
<remote-id type="pypi">pydotplus</remote-id>
diff --git a/dev-python/pydotplus/pydotplus-2.0.2.ebuild b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
index f2a0a8effac2..c8aa79de634c 100644
--- a/dev-python/pydotplus/pydotplus-2.0.2.ebuild
+++ b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
@@ -1,38 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
DESCRIPTION="Improved version of the old pydot project"
-HOMEPAGE="http://pydotplus.readthedocs.org/"
+HOMEPAGE="https://pydotplus.readthedocs.org/"
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# test? (
-# dev-python/flake8[${PYTHON_USEDEP}]
-# dev-python/pytest[${PYTHON_USEDEP}]
-# dev-python/pytest-cov[${PYTHON_USEDEP}]
-# dev-python/sphinx[${PYTHON_USEDEP}]
-# dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-# dev-python/tox[${PYTHON_USEDEP}]
-# )
+IUSE="test"
+RESTRICT="!test? ( test )"
+
RDEPEND="
dev-python/pyparsing[${PYTHON_USEDEP}]
- "
-
-#test phase curently disabled, waiting on upstream to include
-#the required files:
-#https://github.com/carlos-jenkins/pydotplus/issues/12
-#python_test() {
-# ${EPYTHON} -m unittest discover || die
-# tox
-#}
+ media-gfx/graphviz
+"
+DEPEND="test? ( ${RDEPEND} )"
+
+PATCHES=( "${FILESDIR}/${P}-tests.patch" )
+
+python_test() {
+ pushd test > /dev/null || die
+ python pydot_unittest.py || die
+ popd > /dev/null || die
+}