summaryrefslogtreecommitdiff
path: root/dev-python/pydotplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-python/pydotplus
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-python/pydotplus')
-rw-r--r--dev-python/pydotplus/Manifest2
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2.ebuild17
2 files changed, 8 insertions, 11 deletions
diff --git a/dev-python/pydotplus/Manifest b/dev-python/pydotplus/Manifest
index bc17cc5b5de6..6e92a81c00a4 100644
--- a/dev-python/pydotplus/Manifest
+++ b/dev-python/pydotplus/Manifest
@@ -1,4 +1,4 @@
AUX pydotplus-2.0.2-tests.patch 907 BLAKE2B 387823545ea3b1372b6584a4b2daca756eb21d81487e3749309c155e37b21171e8e624d54caecc0b356a1456446a4e3b8340b5fc233301bc270fb3056571a601 SHA512 21dd557a0a94d6ad0e4932e01a97a450d76c0f7bcceab870b0ba60a2b96c711ab139fc682ca2a20da4c68b49fe37577763639bb77b9fbe28c7fa1281f2e5bb4b
DIST pydotplus-2.0.2.tar.gz 278677 BLAKE2B 879271ba7e2104134a71caef7676082420770dcdb34aeabfe76232ad8f9774d3e90a9f7ca5fb407a7a4e8e0c4e5e01824bd0d5936fe77554cc661839fcc0dc7b SHA512 6f06a1f284401123a4514f9e9a4974dee8dc8d01e6b7c40a797fb70eed22b99fe774272f8b106b5632a33f524b356349fe1ff9633101ff61ef2fc3fe69d641ac
-EBUILD pydotplus-2.0.2.ebuild 656 BLAKE2B 3619d05d14fcd707dd15d52c0e46ec6ce61c13de3e76188b085d5169b8bb432e2e5bd6a3481c4ae636b59ce6f1cfce7ace89be54e8b945780c11421424b02a6c SHA512 f8195c8916cd4963124c8b3f3d8fd2cedae02f926e695a2b78d93865fe82de4a8790e8c3f882573ef7b7e5802f06ced6a50d78bad297e4df44347a78f8844d04
+EBUILD pydotplus-2.0.2.ebuild 585 BLAKE2B 44ebcc5815fa3f19abb257b80df372d52b175f01a6b06656ee5d4a807adbc3e25898f9f03e489e8473f4ebeb4ffcc735a3d47debb170b0933d78f88f0d02e83d SHA512 f2ff38c1c65859b1e2f9246f0f166f87f18535a5fb48ae33d37ba22d4afa77ab95019cbd8660a33660bcd1409fb94e30a01c505c7715ff1767c96c9499c303cf
MISC metadata.xml 608 BLAKE2B a3bb72fe1014a3c5a094baff6002a47999c6055d81681b0df29f90d24554cd609b5940b30560d34550ffe3c161a6e76fe05d2a7128a2292f2e8cb4494d7aae30 SHA512 f05b8685f9afe5083512eafb1041f8b868c67b5b97f90f912a13e78717826526c5530af6c11a5e92318f27eab8a875835a66775ff36453fd6f9158dcdeb78a62
diff --git a/dev-python/pydotplus/pydotplus-2.0.2.ebuild b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
index c8aa79de634c..0c5a24a0433f 100644
--- a/dev-python/pydotplus/pydotplus-2.0.2.ebuild
+++ b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,19 +14,16 @@ SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pyparsing[${PYTHON_USEDEP}]
- media-gfx/graphviz
-"
-DEPEND="test? ( ${RDEPEND} )"
+ media-gfx/graphviz"
-PATCHES=( "${FILESDIR}/${P}-tests.patch" )
+distutils_enable_tests unittest
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
python_test() {
- pushd test > /dev/null || die
- python pydot_unittest.py || die
- popd > /dev/null || die
+ cd test || die
+ "${EPYTHON}" pydot_unittest.py || die
}