summaryrefslogtreecommitdiff
path: root/dev-python/pydot/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pydot/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pydot/files')
-rw-r--r--dev-python/pydot/files/pydot-1.0.23-setup.patch21
-rw-r--r--dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch14
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pydot/files/pydot-1.0.23-setup.patch b/dev-python/pydot/files/pydot-1.0.23-setup.patch
new file mode 100644
index 000000000000..c87cc32b30d1
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.0.23-setup.patch
@@ -0,0 +1,21 @@
+--- setup.py
++++ setup.py
+@@ -1,9 +1,9 @@
+ #!/usr/bin/env python
+
+ try:
+- from distutils.core import setup
+-except ImportError, excp:
+ from setuptools import setup
++except ImportError, excp:
++ from distutils.core import setup
+
+ import pydot
+ import os
+@@ -31,5 +31,4 @@
+ 'Topic :: Software Development :: Libraries :: Python Modules'],
+ long_description = "\n".join(pydot.__doc__.split('\n')),
+ py_modules = ['pydot', 'dot_parser'],
+- install_requires = ['pyparsing', 'setuptools'],
+- data_files = [('.', ['LICENSE', 'README'])] )
++ install_requires = ['pyparsing', 'setuptools'] )
diff --git a/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch b/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch
new file mode 100644
index 000000000000..12a01091223c
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch
@@ -0,0 +1,14 @@
+diff -up pydot-1.0.28/dot_parser.py.pyparsing2fix pydot-1.0.28/dot_parser.py
+--- pydot-1.0.28/dot_parser.py.pyparsing2fix 2013-12-09 08:59:24.660145534 -0500
++++ pydot-1.0.28/dot_parser.py 2013-12-09 09:00:10.021222397 -0500
+@@ -25,8 +25,9 @@ from pyparsing import __version__ as pyp
+ from pyparsing import ( nestedExpr, Literal, CaselessLiteral, Word, Upcase, OneOrMore, ZeroOrMore,
+ Forward, NotAny, delimitedList, oneOf, Group, Optional, Combine, alphas, nums,
+ restOfLine, cStyleComment, nums, alphanums, printables, empty, quotedString,
+- ParseException, ParseResults, CharsNotIn, _noncomma, dblQuotedString, QuotedString, ParserElement )
++ ParseException, ParseResults, CharsNotIn, dblQuotedString, QuotedString, ParserElement )
+
++_noncomma = "".join( [ c for c in printables if c != "," ] )
+
+ class P_AttrList:
+