summaryrefslogtreecommitdiff
path: root/dev-python/pydocstyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/pydocstyle
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest5
-rw-r--r--dev-python/pydocstyle/metadata.xml24
-rw-r--r--dev-python/pydocstyle/pydocstyle-2.1.1.ebuild34
-rw-r--r--dev-python/pydocstyle/pydocstyle-5.0.2.ebuild36
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
new file mode 100644
index 000000000000..df8a78dee222
--- /dev/null
+++ b/dev-python/pydocstyle/Manifest
@@ -0,0 +1,5 @@
+DIST pydocstyle-2.1.1.tar.gz 55760 BLAKE2B e470b006b5db04c4bed5c3145b14b949980c71d1dd91dbe34d49599063aaf1cb1d0842dfb992e5d471436446455bde2d309ee573826c039540fa99adba3f828b SHA512 f23939e0350094c67565613bab4ddf285dda5a7379e6ac2493953d6e60ab75588143fd374715765d2aa0728e7117d02e91312dbbe5a9cad28aa8e8e7f68e3bc4
+DIST pydocstyle-5.0.2.tar.gz 68063 BLAKE2B 6d7bf04e97c853e50d953342d332847d0e80b080d5ab044f9d444536ed0352ad44402a1af0c3a6f552ec9f3bb3a372a84af2a5bbdaee58bb18dab585cad5dddb SHA512 5ac2e017ae95ff5c7759d6a2cb9ac990f94f668f5fd940792d927cc62628cd036afcf39ab5db6a11100dcca32af344b47f4a7319dd3a47c36367844d0c06d34a
+EBUILD pydocstyle-2.1.1.ebuild 666 BLAKE2B c6313ec1ee780c6a83d7bdb5f538921752754d14c78f38bbf81dfb77eaaecede508971d79fba871db1c4ae703b40304168aa18b4b0e0714260a5e68083d02a88 SHA512 6fab1a22948e47fabf6ebf37a636b07ad68f5994205223c1dd1124e2261b1bf9ad5fd62524984b33d660c6e831067b71fbdfc8bc454cd247027343684a6e4a49
+EBUILD pydocstyle-5.0.2.ebuild 909 BLAKE2B e4ed41f34eef035c54e5fab60419245603d7b00030c8f67c249af7d4569fb0bf093b6df059dca37746d473460e5a91ead64b877fcd87d409b6dfe435d7321416 SHA512 1f1b484de5da8c4130135110a187e415fd271670e166a62ab064243e25c64a623448fb514f1c9c1633405b409b17cf396a9c7f4bd7b87f5e83ad260ff6991242
+MISC metadata.xml 762 BLAKE2B 3beb9d084f02d336a8b8785df8bcad21c5e49f972b3a9a255eba79291630a1cb6dedd77d1a6c72c7cf787149b6a8ed0c4df2cc49dfb3eb0d9094ca271bbd5220 SHA512 8c3ddff21e08bce744df0d7f6157e0024f13f4e6dbc51c053b46058152c6c889ab529dcc423659f993b79b8292a5a76ad1bb161e3fd949a9bc3a3e7b416a86bb
diff --git a/dev-python/pydocstyle/metadata.xml b/dev-python/pydocstyle/metadata.xml
new file mode 100644
index 000000000000..17a622fcf6ba
--- /dev/null
+++ b/dev-python/pydocstyle/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Gentoo Python Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PyCQA/pydocstyle</remote-id>
+ <remote-id type="pypi">pydocstyle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydocstyle/pydocstyle-2.1.1.ebuild b/dev-python/pydocstyle/pydocstyle-2.1.1.ebuild
new file mode 100644
index 000000000000..6f1106d04f61
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://pypi.python.org/pypi/pep257"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild b/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild
new file mode 100644
index 000000000000..65c6d9cc32c2
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+src_prepare() {
+ default
+
+ # These tests call pip.
+ # pip install fails because we are not allowed to do that inside an ebuild.
+ rm ${S}/src/tests/test_integration.py || die
+}