summaryrefslogtreecommitdiff
path: root/dev-python/pydocstyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pydocstyle
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest2
-rw-r--r--dev-python/pydocstyle/pydocstyle-5.0.2.ebuild10
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index cd8ff41d4ff4..24b66d8f0227 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1,3 +1,3 @@
DIST pydocstyle-5.0.2.tar.gz 68063 BLAKE2B 6d7bf04e97c853e50d953342d332847d0e80b080d5ab044f9d444536ed0352ad44402a1af0c3a6f552ec9f3bb3a372a84af2a5bbdaee58bb18dab585cad5dddb SHA512 5ac2e017ae95ff5c7759d6a2cb9ac990f94f668f5fd940792d927cc62628cd036afcf39ab5db6a11100dcca32af344b47f4a7319dd3a47c36367844d0c06d34a
-EBUILD pydocstyle-5.0.2.ebuild 907 BLAKE2B 90267da429cbb2ca73745f1fcef6571f6b7b35cda0c2440acc62a640ad17c2d2a98d03684c28f777a37114b29fe58c77645c0ff89b8fbbe977185bfec300a229 SHA512 acc11f13453bafc2494c3a522a4e11c5d3b973951b67fa23bcd5032bef59a05f3227e2dd4a5e95b973b950b8530124369537123c1bfda586f9694766b6f8f3c0
+EBUILD pydocstyle-5.0.2.ebuild 955 BLAKE2B c2f040156346bcb23a85f42b6b7ff3ed0d8d59321b5da4fb8fb8f5c4ab795b4cea15b9547324ea3e920f3525aeb2f8bbc69653928233e51fcc85cfcabe96c72b SHA512 9f401abfdf48c389747a92b2a84668fced98e6cb624d8dd2fddc472bbbe5c0428e291c43437220adc7630917b81ec6cf109e789e676f89c979f98622a6143792
MISC metadata.xml 762 BLAKE2B 3beb9d084f02d336a8b8785df8bcad21c5e49f972b3a9a255eba79291630a1cb6dedd77d1a6c72c7cf787149b6a8ed0c4df2cc49dfb3eb0d9094ca271bbd5220 SHA512 8c3ddff21e08bce744df0d7f6157e0024f13f4e6dbc51c053b46058152c6c889ab529dcc423659f993b79b8292a5a76ad1bb161e3fd949a9bc3a3e7b416a86bb
diff --git a/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild b/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild
index 5d439c03ab4f..42c63035e5e5 100644
--- a/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild
+++ b/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -22,15 +22,17 @@ RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
DEPEND="test? (
dev-python/pytest-pep8[${PYTHON_USEDEP}]
dev-python/mypy[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}] )"
+ dev-python/tox[${PYTHON_USEDEP}]
+)"
distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
src_prepare() {
default
# These tests call pip.
# pip install fails because we are not allowed to do that inside an ebuild.
- rm ${S}/src/tests/test_integration.py || die
+ rm "${S}/src/tests/test_integration.py" || die
}