summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pydevd
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest4
-rw-r--r--dev-python/pydevd/pydevd-2.7.0.ebuild2
-rw-r--r--dev-python/pydevd/pydevd-2.8.0.ebuild88
3 files changed, 92 insertions, 2 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index f63765b9a4f3..6fc0ca86aead 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,3 +1,5 @@
DIST pydev_debugger_2_7_0.tar.gz 4154343 BLAKE2B 6504ffa5eee5548a6aa9e59712b6c0054b69c2e0f6ff48059ed8b2e3edb92ec92ea4e7f9ff084419b46310c4d08f11008571cbf70ccc4efddd0fae688e4110f5 SHA512 8f09b446eeaace1f9ecd3d331813e8bd7d8e09e1fe9dc9fa955ecc26a97ac6015f7becc4005a87405d1154280ec10eb7fa87914bcd41f27e51d90ad3eb99f643
-EBUILD pydevd-2.7.0.ebuild 2513 BLAKE2B 62541e624063f3da71c2b49844a56107188ac1a575ee3aa937e47ff52749c245b34662b56a9886c9942f326cab6dda9a0cf565cc5c65224fa336e1a72a10c585 SHA512 612895ca491d5de568ba9b8566d507f62a7f4bacfb46ba07cfe6b26220916caa255c07d241e22907c772dfad10bd5992863e5db5440c9738c8e5a0d590b4b56a
+DIST pydev_debugger_2_8_0.tar.gz 4171117 BLAKE2B 4f0ea0eeb228cb66f71e2046438396ff5ce59b42e620a067bc515ff504fa2da151e05f8ea6cf2d1aaa0768122431ccb45708a88c0616fb2859e96671b172e822 SHA512 b0189f1824b52f8ad35d1d1cfba0bd734806541ae2ff4f410c110763201630d296d10c2b7eaac8c656dfb3ff0f3c31bfdf2de28323778000cc7821e123a877d3
+EBUILD pydevd-2.7.0.ebuild 2520 BLAKE2B 0c93fd2f6f1934367257ce764e9a67dd68b0d1a694042b4f4670d7b82ac7f7ec8e310e5380e72692bc22f952b8edf4725e697718709c5476112dbcd1a33b2fb6 SHA512 9c30ea78725720902e25f337c20f8a13d612198bf73272a874036838679dc636a189b29afc22fc8e5ad227d965a846c875fec9e5623690598951b878244684ee
+EBUILD pydevd-2.8.0.ebuild 2559 BLAKE2B 9033a19f36cfc7a84f20519165730c3244a97fe0f96c5069e5ba5246e7fa6eb618eac5cfea271bf35209c8421389edd551ce5e67066c4a1aa5acac3f90ab4932 SHA512 90d06b29d74683a20ec75fc6b4e6ddd9c44c01d93baf5361620755bd780e74a3f7d95b566e8ebc4fa9a2ba47b4ca5ad5ec2df555f44adcc0f141e6547e5151af
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-2.7.0.ebuild b/dev-python/pydevd/pydevd-2.7.0.ebuild
index 32fd37a4fb83..6bdca5078bd1 100644
--- a/dev-python/pydevd/pydevd-2.7.0.ebuild
+++ b/dev-python/pydevd/pydevd-2.7.0.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/PyDev.Debugger-${MY_P}"
LICENSE="EPL-1.0"
SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
# After removing and recompiling the prebuilt lib the tests fail?
# For some reason the test suite is executing a slightly different gdb command
diff --git a/dev-python/pydevd/pydevd-2.8.0.ebuild b/dev-python/pydevd/pydevd-2.8.0.ebuild
new file mode 100644
index 000000000000..3b8e00c75fbc
--- /dev/null
+++ b/dev-python/pydevd/pydevd-2.8.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 toolchain-funcs
+
+MY_P="pydev_debugger_${PV//./_}"
+
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
+SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/PyDev.Debugger-${MY_P}"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# After removing and recompiling the prebuilt lib the tests fail?
+# For some reason the test suite is executing a slightly different gdb command
+# then before, which is lacking the file name of the lib that was pre built:
+# gdb: No symbol table is loaded. Use the "file" command
+# This also happens outside of portage so it is not related to any *FLAGS
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/untangle[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# Block against the version of debugpy that still bundles pydevd
+RDEPEND="
+ !<dev-python/debugpy-1.4.2
+ sys-devel/gdb
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Drop -O3 and -flto compiler args
+ sed -i \
+ -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
+ -e '/extra_compile_args/d' \
+ setup.py || die
+
+ # Clean up some prebuilt files
+ rm -r third_party || die
+ cd pydevd_attach_to_process || die
+
+ # Remove these Windows files
+ rm attach_{amd64,x86}.dll || die
+ rm inject_dll_{amd64,x86}.exe || die
+ rm run_code_on_dllmain_{amd64,x86}.dll || die
+ rm -r windows winappdbg || die
+
+ # Remove these MacOS files
+ rm attach_x86_64.dylib || die
+
+ # Remove these prebuilt linux files
+ rm attach_linux_{amd64,x86}.so || die
+
+ cd linux_and_mac || die
+ rm compile_mac.sh || die
+}
+
+src_compile() {
+ pushd pydevd_attach_to_process/linux_and_mac || die
+ # recompile removed file (extracted from compile_linux.sh)
+ $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} -o "attach_linux_${ARCH}.so" \
+ ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
+ mv "attach_linux_${ARCH}.so" ../ || die
+ popd || die
+ python_foreach_impl distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process" || die
+}