summaryrefslogtreecommitdiff
path: root/dev-python/pycxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
commit4fe228ee9aa3b9b825d54ace549a5517e153e8bd (patch)
tree90a261e3ea59b80722d70d3c42f3e40d16c9f8dd /dev-python/pycxx
parentadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (diff)
gentoo auto-resync : 09:06:2024 - 00:08:13
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest1
-rw-r--r--dev-python/pycxx/pycxx-7.1.8-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index 26c4a9558ac6..f437f70f7e55 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,3 +1,4 @@
DIST pycxx-7.1.8.tar.gz 154789 BLAKE2B e4b635d4b53ae3fd0790d6eddcd465acfc5272213e9752e7c2a1840edddb66f09bc9617373246964859125a27dc82110de6b4f4ffa44c41c94c338c846490e47 SHA512 3c9c3a23dfa9777c6a48b8600e7336cbadb60080a1051071583d534ead6c691dd9d304613073d6fb0c632eb1703b043b4214826c0ae7bd4b2ca72203ec03c0a2
+EBUILD pycxx-7.1.8-r1.ebuild 1216 BLAKE2B fc032ad757671f8bebf802d9036a5441a8fcdd203bf6c8414ab2bdf1ed4b0c1843be505a5eaa277d9c2b7355f4d1abe8e770590f7e92fb0f06b9b6312d38955c SHA512 646b9c8e35817ef449a3a458413379d4c8de8f87bde9bd8587a6f8a2efd7b76873c0afbdf9f0033faf6563b24ac2f861da0d332803de3cee20d053be031e4fbe
EBUILD pycxx-7.1.8.ebuild 1077 BLAKE2B 8d8bb19fad2ced63e76749c2b61e63f5a92d147dd87ea5de953f708fd86181f19e5f04ab00994127d16a57a5e32a38b548b20a2190e54b62e715a93e2e5e55a7 SHA512 8188aad1b1331b115e5f199aafed3b069374e5b819cbc68f4faa39f8298ff0db654a17ac44cebb29d9f3726804a5830dbb10207fa16f945a1966215acc0d5e27
MISC metadata.xml 741 BLAKE2B 0704aeaef1fff687aa8374876e9d275a135d4ead7fabc938d8b3dc60954717fcf01bb79e8e9a72483184b13441d65294f41f7b5b0b19bebbf42c0934993723f4 SHA512 0b4f912fa2e38882bcaecede459f34270dd222a94bf70fa019e8de1eb1097c9c9016405b9b8a7933fd7839f11404a18c5e2ce7d4b4336a7121e86605903a8901
diff --git a/dev-python/pycxx/pycxx-7.1.8-r1.ebuild b/dev-python/pycxx/pycxx-7.1.8-r1.ebuild
new file mode 100644
index 000000000000..937f1bf9eb40
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.8-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="https://cxx.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' 3.12)
+"
+
+python_prepare_all() {
+ rm -R Src/Python2/ || die
+
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Move misplaced files into place
+ dodir "/usr/share/${EPYTHON}"
+ mv "${D}/usr/CXX" "${D}/usr/share/${EPYTHON}/CXX" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python3/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}