summaryrefslogtreecommitdiff
path: root/dev-python/pycurl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pycurl
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest3
-rw-r--r--dev-python/pycurl/metadata.xml22
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.ebuild74
3 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
deleted file mode 100644
index 6e3d26c1a670..000000000000
--- a/dev-python/pycurl/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pycurl-7.43.0.tar.gz 182522 BLAKE2B af6c85934565d851ea2280253ec6c61ab85f2dea047c83fc5ad65a6f05d3b8bf97932a161ae171c573a7333a99f2a25d4280c70be7ed3aef5eae19b5c392f5c7 SHA512 7442462c74c19964b9d72976e9b92bf68bb37debc1401bc399590bea42704065da13d6de710e795eeae79a4651b9a08841d50454243cb0994c7eb1c1bab233a5
-EBUILD pycurl-7.43.0.ebuild 2539 BLAKE2B 7899ee6b5c2f66dce55058480a38f87d55bb60ffabb63461a3b2e078566e1c3a930e34b4c5745bf3e839e5e204177623df460d3515295c0027e06d7ed99d90a3 SHA512 a17ede29527bce67fc7389cf59cda1de096103646366b79b4b9098eb9a96ccc6b147a6f724c868f3f6f9df98591ebf3563ca96fa0d2c813d4563126d902625e8
-MISC metadata.xml 1099 BLAKE2B d96159920135d8d85a01449423d1638889d2c6ed9f84d08eabd7405a3271efe85315cece0fc4f6832bd43b622089c819df3d20fd725150c89a0910ec26ac339a SHA512 8f8b3a10d2f72aa67d1b5f7462ea62803d9150cab3d96792adbd65b379a45c074d68809b25d4a2b558bf28dae72e095c598bd0485fce4c5dafba0784de517a6c
diff --git a/dev-python/pycurl/metadata.xml b/dev-python/pycurl/metadata.xml
deleted file mode 100644
index 7ba6d7c3aadd..000000000000
--- a/dev-python/pycurl/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
-PycURL is a Python interface to libcurl. PycURL can be used to fetch
-objects identified by a URL from a Python program, similar to the urllib
-Python module. All the functionality provided by libcurl can used through
-the pycurl interface.
- </longdescription>
- <longdescription lang="ja">
-PycURLはLibcurlへのパイソン・インターフェイスです。PycURLはPython言語モジュールの様に、Python言語プログラムからURLで指定されたオブジェクトをダウンロードするにも使えます。Libcurlで利用できる機能全てはPycURLインターフェイスを通して利用できます。
- </longdescription>
- <upstream>
- <remote-id type="github">pycurl/pycurl</remote-id>
- <remote-id type="sourceforge">pycurl</remote-id>
- <remote-id type="pypi">pycurl</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pycurl/pycurl-7.43.0.ebuild b/dev-python/pycurl/pycurl-7.43.0.ebuild
deleted file mode 100644
index 171d54abcf8f..000000000000
--- a/dev-python/pycurl/pycurl-7.43.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# The selftests fail with pypy, and urlgrabber segfaults for me.
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="python binding for curl/libcurl"
-HOMEPAGE="
- https://github.com/pycurl/pycurl
- https://pypi.org/project/pycurl/
- http://pycurl.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl examples ssl test"
-
-# Depend on a curl with curl_ssl_* USE flags.
-# libcurl must not be using an ssl backend we do not support.
-# If the libcurl ssl backend changes pycurl should be recompiled.
-# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
-# does not need to initialize gcrypt threading and we do not need to
-# explicitly link to libgcrypt.
-RDEPEND="
- >=net-misc/curl-7.25.0-r1[ssl=]
- ssl? (
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
- curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0 )
- )"
-
-# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
-# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
-DEPEND="${RDEPEND}
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose-show-skipped[${PYTHON_USEDEP}]
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),kerberos]
- >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
- )"
-# Needed for individual runs of testsuite by python impls.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
- sed -e '/pyflakes/d' -i Makefile || die
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # Override faulty detection in setup.py, bug 510974.
- export PYCURL_SSL_LIBRARY=${CURL_SSL/libressl/openssl}
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- emake -j1 do-test
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}