summaryrefslogtreecommitdiff
path: root/dev-python/pycups
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-python/pycups
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-python/pycups')
-rw-r--r--dev-python/pycups/Manifest4
-rw-r--r--dev-python/pycups/pycups-1.9.73-r1.ebuild31
-rw-r--r--dev-python/pycups/pycups-1.9.73-r2.ebuild31
3 files changed, 6 insertions, 60 deletions
diff --git a/dev-python/pycups/Manifest b/dev-python/pycups/Manifest
index 2af65262e722..7e8202d0e606 100644
--- a/dev-python/pycups/Manifest
+++ b/dev-python/pycups/Manifest
@@ -1,4 +1,4 @@
DIST pycups-1.9.73.tar.bz2 52732 BLAKE2B a6c9750970548ba85cdef4041f716491e9b0cf4273cb5381bca8e57deab457affaa62eccf74d36eb3f8b047e5142c952e56e7e624f85ed7959a769f568824f26 SHA512 ee893d64f1645b71805ac358c4a3cc594f6285f04272ff0558aa60cbc90fafdbac30b623ffcc3a6b739218d9fd7a6a6e1d8cb186a5582f2cc30a518ed4dde810
-EBUILD pycups-1.9.73-r1.ebuild 1410 BLAKE2B fbda30b81cedc43000e4170795cd6ebe7a42184e5c5cf377ed487fbfc84d393af9d567bcd52cf2e20e6fe525d0c31d6e954c2c015d54a3c1c784b20837fb1a60 SHA512 e6f973c53d2171c72e27c85acc7b5cda71e21c591974cf388c432f324116236cc32c547ca8d5bad132bfa5b58644fca1bc37d147ad810aba00354e7d4a4181d0
-EBUILD pycups-1.9.73-r2.ebuild 1414 BLAKE2B 68060b212b39f8cbec8fad18b6094f800e0464b9922c99ef1ef5dde54a26b15cf2bba513b5f5ce1241c1e0d4ed50f1beb0776be550dff96c0c7af2b858051cdc SHA512 d75f20cd92ff2df5c5d0d8472d58d6fb5512708000810757c2784ae2f390b8b8c751c155012256dcc95c6f828311c2ff7e32ffd49db148147ee6176a0f96eeab
+EBUILD pycups-1.9.73-r1.ebuild 666 BLAKE2B b9fad8d66624f027226cce6720b44e742cd7337aee753b19928c1e9a4eb933fabaf24b869c55942dc88122d01931ced3ab217f264ee3ae353d91623c8ef87692 SHA512 c16267b3e45c3d27cfe8620197a92c308ffc723e3ee06ed2b39470210de5786e4bbeb9a030a6dcc6b112b285f91a24aa7d8b07b102367f90ba86e72f5bf84c90
+EBUILD pycups-1.9.73-r2.ebuild 672 BLAKE2B 09926fe4e69e0142bedcd54bb6e0688b6722d8ef5f7625ef86c59d1cd1bc3a6232f62599221958efec4f32bc6952d4258c6b4cc9a563234b1566b4bfa00b87f0 SHA512 5b394c208a504968b6ff3efe2f13cc82118f5ea44d6fb0d69733b6321d30054107bc768898113c77e26e98569fd9e17bd7815d6cc13054ca43cf93171eeb1fba
MISC metadata.xml 456 BLAKE2B ea7d7af9ed2baa3cb5270b3da9c5e1c6dc64d1391e0b280ddd1a6e3e8f3317808eb3906e1c9551615ac2218b89685b9ccbfb4d4656e80eeb54cf2d8dec2149c7 SHA512 c8318d150b07e8a369037201bcb9a99a7bc8c406a2a2889f4a1af62166313d4db740e8546f78f0de1e80cddf774f8818e49a4d3e99e906456ffc2f46a562e7ea
diff --git a/dev-python/pycups/pycups-1.9.73-r1.ebuild b/dev-python/pycups/pycups-1.9.73-r1.ebuild
index 739e5b77d606..2fc406f3ca50 100644
--- a/dev-python/pycups/pycups-1.9.73-r1.ebuild
+++ b/dev-python/pycups/pycups-1.9.73-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python bindings for the CUPS API"
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~sh sparc x86"
SLOT="0"
-IUSE="doc examples"
+IUSE="examples"
RDEPEND="
net-print/cups
@@ -23,33 +23,6 @@ DEPEND="
${RDEPEND}
"
-# epydoc kinda sucks and supports python2 only (it's dead too),
-# and since we're dealing with a binary module we need exact version
-# match. therefore, docbuilding *requires* any python2 being enabled.
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- # we can't use Makefile since it relies on hardcoded paths
- epydoc -o html --html cups || die "doc build failed"
- HTML_DOCS=( html/. )
- fi
-}
-
python_install_all() {
if use examples; then
dodoc -r examples
diff --git a/dev-python/pycups/pycups-1.9.73-r2.ebuild b/dev-python/pycups/pycups-1.9.73-r2.ebuild
index 5cc54abd0a77..f1ce8a33d076 100644
--- a/dev-python/pycups/pycups-1.9.73-r2.ebuild
+++ b/dev-python/pycups/pycups-1.9.73-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Python bindings for the CUPS API"
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~sh sparc x86"
SLOT="0"
-IUSE="doc examples"
+IUSE="examples"
RDEPEND="
net-print/cups
@@ -23,33 +23,6 @@ DEPEND="
${RDEPEND}
"
-# epydoc kinda sucks and supports python2 only (it's dead too),
-# and since we're dealing with a binary module we need exact version
-# match. therefore, docbuilding *requires* any python2 being enabled.
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- # we can't use Makefile since it relies on hardcoded paths
- epydoc -o html --html cups || die "doc build failed"
- HTML_DOCS=( html/. )
- fi
-}
-
python_install_all() {
if use examples; then
dodoc -r examples