summaryrefslogtreecommitdiff
path: root/dev-python/pycollada/pycollada-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pycollada/pycollada-0.4.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycollada/pycollada-0.4.ebuild')
-rw-r--r--dev-python/pycollada/pycollada-0.4.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pycollada/pycollada-0.4.ebuild b/dev-python/pycollada/pycollada-0.4.ebuild
deleted file mode 100644
index 91e85d338acd..000000000000
--- a/dev-python/pycollada/pycollada-0.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_MULTIPLE_ABI=1
-
-inherit distutils-r1
-
-DESCRIPTION="python library for reading and writing collada documents"
-HOMEPAGE="https://pycollada.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? ( dev-python/python-dateutil )"
-RDEPEND="dev-python/numpy
- dev-python/lxml
- >=dev-python/python-dateutil-2.0"
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc ; then
- pushd docs
- emake html
- popd
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-
- if use doc ; then
- pushd docs/_build/html
- dohtml -r *
- popd
- fi
-
- if use examples ; then
- insinto /usr/share/${P}/
- doins -r examples
- fi
-
- install_test_data() {
- insinto $(python_get_sitedir)/collada/tests/
- doins -r collada/tests/data
- }
- python_foreach_impl install_test_data
-}
-
-src_test() {
- test_collada() {
- for script in "${S}"/collada/tests/*.py ; do
- PYTHONPATH="${S}" $EPYTHON "${script}"
- done
- }
- python_foreach_impl test_collada
-}