summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/pycodestyle
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.6.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 7a37c69d3940..ceaf4e4b3383 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,3 +1,5 @@
DIST pycodestyle-2.5.0.tar.gz 98802 BLAKE2B ec86642f0f37abc4da8886df6395694b54cbe4e1d0030615b2136f0bc265825df254f019483e9094feaad685e43008cefdf0e50b533df434a40de0de11aa5fa1 SHA512 84e751a7d00048393b02ca743de5d71d1641e948ee1b4daebbdf2d07e0cd8f087ca4e81f826061114b40ef41920bbcd680c9f479e7cc1a159a70188425717208
+DIST pycodestyle-2.6.0.tar.gz 100213 BLAKE2B 484cad34de86ae50f8efaffe590e79fa52ca7f13a3a9d5c9d52f52aef7a940a9eee8cff74b3bd1f711c3a01155f0ce6794196817d1b0e941b8afc77de4804387 SHA512 3bf9904752170135ca399a1b25470a531adb5b85dfd8df7ffbbc86b5875bc3a507cd8732158bc9cb7fd5b44b48c9a32d63d621856d55a15bc3104a99ca4bd271
EBUILD pycodestyle-2.5.0-r1.ebuild 1130 BLAKE2B 130e4b41354b1a24331e91b9406a47752a3c8466973bc90cec38973fee2e235f41d7f9abc86907b723898a72b5676709f1bb204bc6da845f0ce78fb508f21560 SHA512 df471dddd80d5b9a4f63f0e5a0c29167be7956f51448b73d0f88946c690315c0757d09b5ef6c684a366444723a94be9dbd9d66eced6e1ad079a492a5d8a71be4
+EBUILD pycodestyle-2.6.0.ebuild 915 BLAKE2B b908605cdba0a13ccd0364f86d96f8cdf634afe2cfcc9a448d7d785be12d8edac2a9251d5ce9da8eb27ba46bfe95fc84cc27e2b2a75f0622b0454547c9252fe1 SHA512 c8dd899a75bbe7ac96dfe15236156f1e950cc89c1d6d9db206ebfba1043d6f1bea4b99dcb22c4a1d10513a9091f89ca14a428df18a256753826bdbc4bed81246
MISC metadata.xml 335 BLAKE2B 9ecbe193a8f7aaf12005920847cd3d8a34b868636a943ba30465a4eead591ce46d422bd0b0e777a86f0d5c4efd5ed925a1476f18f659f18e622dfab057df0d8e SHA512 92e19ab42f44fe1a1da2c8407214bb447262a818b2051e644851178cc7f2274198310a85d7c094839b1764664bd8f8463a6a7a96df83447768082c8ab44909c4
diff --git a/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
new file mode 100644
index 000000000000..04692ec49c1d
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.org/project/pycodestyle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests setup.py
+distutils_enable_sphinx docs
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+}