summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 20:05:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 20:05:57 +0100
commita87d0d6b8bfa400637c56d3194b22fca5cbd6f9e (patch)
tree761432665eb6bfa18b129f0bc7b23162bcfd98fc /dev-python/pycodestyle
parent9ec9cbf23e468492eab5e3a31836c699e8c5c534 (diff)
gentoo auto-resync : 04:08:2022 - 20:05:57
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.9.1.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index c95560d71a04..841ff84e68f7 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,5 +1,7 @@
DIST pycodestyle-2.8.0.tar.gz 102299 BLAKE2B ac4708a513582bb0f27f1abfcc983319e6c7b853c53971d5f026f297f897b25a6c8a651a4d2441b19ab37e6df6f7a38a472aad0757fec59e0438263d76ccfdb2 SHA512 0098be44451bc173507e2b396aaf342ccf7f25a6a1f5d5c1f802079a76a66e6bedf9f358b5e07b27bee66e3b279c72a6b72f63e5984f58ae83b7fc5806880fc1
DIST pycodestyle-2.9.0.tar.gz 102014 BLAKE2B ee2c2cad332e7442f9e557f388c3de09ea0ea65b0678c65d64d6293de18aa884a39a6a65ce47a99ac04b98da4e4bad14d2ccd228b22bdbd7361a3a0ca2c27afb SHA512 82926bf1c5b72decc0679d4fcec705d707b91b347ea0eec52b1f05301b96e55fc75afdb367ecdec674976fe1f2f7b475498a8e9a2ba19e3dfd483584a9ef841e
+DIST pycodestyle-2.9.1.tar.gz 102127 BLAKE2B 701e6325a73173b8ab8540f03f794066f05ffe7f29cfac49f065ec6f8cc6a50b1334372b8fd7619a368a54605dde0214da9e9b3b59326c58803bf7f49d6981ea SHA512 da1c67815b50d13c8eb70cebcc12c761a6407518a4ed4a8780ee7064089c9e89a5c3246d05f19916c0ec293fc1a372d3b2adb72e11f775b1cfbd1fbbe07a1a83
EBUILD pycodestyle-2.8.0-r1.ebuild 988 BLAKE2B 1a03070b2034e0980a1bcbccea10fb802cf8d29103ade396ad4834cbbe1b7f63c11e771467cdd53c188a0ee7025e5c0c5e7d7cc06d179d2d40c2e30194bdde99 SHA512 7ae95a135f574daea73067a52cd143bf502f54706264c7736673ed552cb7cd1bc33f2017f3fb8726d1605d86acfa294a469b9ed7e9fe69ac13ff61b55b1acc29
EBUILD pycodestyle-2.9.0.ebuild 1067 BLAKE2B 440eb3e87210bbc3b2b013daec2ab9eb89c5d759d9a0d9553d1d817fe09a722281a7e478fcc34276ebcb38be84471bcf74263dc4d86ec1e7ef540fbcde348f0f SHA512 d3d9712990c3204b4d790f3ada1d438ab2618b6a34da97a647b2af73ab423845fd30181c3c6687fafbbe73c8ba8627cebe402080e050270bffbf766e2d514a7d
+EBUILD pycodestyle-2.9.1.ebuild 1067 BLAKE2B 440eb3e87210bbc3b2b013daec2ab9eb89c5d759d9a0d9553d1d817fe09a722281a7e478fcc34276ebcb38be84471bcf74263dc4d86ec1e7ef540fbcde348f0f SHA512 d3d9712990c3204b4d790f3ada1d438ab2618b6a34da97a647b2af73ab423845fd30181c3c6687fafbbe73c8ba8627cebe402080e050270bffbf766e2d514a7d
MISC metadata.xml 350 BLAKE2B 6ca2711d99bb29041b5cc2a65218ace68f8d4f2d1d2d0a19f62d17f2340cc44faa7488d4eb29b72e86a0b2f003ea6a2df5f5d4e7d95894ff9c8c229bb6441156 SHA512 db79cd77edb6be824903614c78a39f427af51e940c0b08e1512c264b634ef3474fdba21a1a8b6c9458c2687f871d9374ea5f9b5080da4f6e652dd919e89d990c
diff --git a/dev-python/pycodestyle/pycodestyle-2.9.1.ebuild b/dev-python/pycodestyle/pycodestyle-2.9.1.ebuild
new file mode 100644
index 000000000000..509d1524f65a
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local -x PYTHONPATH=${S}
+ "${EPYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" pycodestyle.py --doctest -v || die "Tests failed with ${EPYTHON}"
+}