summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pycodestyle
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.5.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 7d7a8bda54fe..2f48dd40f68a 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,5 +1,7 @@
DIST pycodestyle-2.3.1.tar.gz 89460 BLAKE2B 0b7e23be13830954277d521262e9504ade8a4d0275a77e6365201ccffae955a8f505a1cd5e739145e1fc5551c3b956ff9a51bb57cede819f2886ee36637f7f9e SHA512 276bc21b4e6898e379be88f3582135a21314460ad20d4b6c3e12825ac1a72082b2c08bb62099e704c3222f879a1098d0b305132fac1095aaa60ca239b9763a2d
DIST pycodestyle-2.4.0.tar.gz 96665 BLAKE2B 9c847aa9c9ffa1f401595d1c2c3f81f971f69628fb34d4e572ccb99203f8e9abe8101302d61c4ae7d330c03e7d0dd5e252d658065b7ed6660dea186880030529 SHA512 cb35238291fed30f1a4363e65b754165772d01e6006e19ce31769691aed17411cd893899fcd22dfca0455401bee899097fff6f3d63825c7656f186e37b7da3a0
+DIST pycodestyle-2.5.0.tar.gz 98802 BLAKE2B ec86642f0f37abc4da8886df6395694b54cbe4e1d0030615b2136f0bc265825df254f019483e9094feaad685e43008cefdf0e50b533df434a40de0de11aa5fa1 SHA512 84e751a7d00048393b02ca743de5d71d1641e948ee1b4daebbdf2d07e0cd8f087ca4e81f826061114b40ef41920bbcd680c9f479e7cc1a159a70188425717208
EBUILD pycodestyle-2.3.1.ebuild 1114 BLAKE2B 84b7823ef5f606038179c26f5a1df0126054d5fbd2911ce61cec047ee4ba85a981b740ff8bd19bbd86c28ea891f69bf60c82a400dcdb3b31712aff8c4336ec3b SHA512 eb6987e581d2a4689320cce62216a3df8d21f95aaa0d84d3ebe8e52661e84a4c56ae0d549cce2f76b588ba37163f45bf5064d725726ccaec7700015f677e1f63
EBUILD pycodestyle-2.4.0.ebuild 1120 BLAKE2B 6d98e5ba715eb279fbcb3242431d4cfe924db9b914c727b531baf1f1ab1595b47284fbf89eae3d32fb9a65c3b68acacbf4b4f289104e669909893c74cd2f140e SHA512 490127c1b7563a7bec091028dfeebd9f76852f23f41a11185d6289f4a9c6efb35018231a42fd8c0e363d225909e1b3a6dad16bb46bdca9013f331912b3a6d11f
+EBUILD pycodestyle-2.5.0.ebuild 1109 BLAKE2B fa34c43d20ab1ead3b26dc7f085aee48794e89a7428c8ea7e5bc8c2764076cafbab0f256bbdbfc1b93fb827ce500769e834293e55d57b10a771964f6cdde34df SHA512 cab325badcde62a719412e8cc257342ccfde80af4ff34b8cf05f4d7e432486c783ed595db0ff0ff346efb498c4a748aca671ce692148dfc4f81256a05706892f
MISC metadata.xml 335 BLAKE2B 9ecbe193a8f7aaf12005920847cd3d8a34b868636a943ba30465a4eead591ce46d422bd0b0e777a86f0d5c4efd5ed925a1476f18f659f18e622dfab057df0d8e SHA512 92e19ab42f44fe1a1da2c8407214bb447262a818b2051e644851178cc7f2274198310a85d7c094839b1764664bd8f8463a6a7a96df83447768082c8ab44909c4
diff --git a/dev-python/pycodestyle/pycodestyle-2.5.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.5.0.ebuild
new file mode 100644
index 000000000000..37e81701a84f
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python2_7 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.org/project/pycodestyle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}