summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-13 12:17:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-13 12:17:26 +0100
commit41c2683a5cfac2bd3280dc5d5aaed73b6c377bcf (patch)
tree05752a3fb2f0dba34c0384a9178c0fd4c5b3cadb /dev-python/pycodestyle
parent3b0753af8a3a0f5ac9f7248d90393dcc0d3a84c1 (diff)
gentoo auto-resync : 13:10:2023 - 12:17:25
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.11.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 7018d1f3ad82..1a6c03dab434 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,3 +1,5 @@
DIST pycodestyle-2.11.0.gh.tar.gz 79772 BLAKE2B 5995cae91a9e1109b697fae840d1dccd4778096dded7357bdbca1a56b06a031fc524f638e91192564f127b2bc52e94c9e80b2437daac5a129db48f99ca701e48 SHA512 fd688544a7fb01a7e3f4f8cb411cf7bc5b6dfc357de616a2ef61944748ad670c239148766b8ea48a3c316396251ed8a8d8937446f400c28e631621a0d16d3cf5
+DIST pycodestyle-2.11.1.gh.tar.gz 79865 BLAKE2B b4d9ab3d50aba87e7194abd6b3b317183932cd9e5331c95b57f498704643bce2f459ca9fa2016cc2544f31fb9cbe3390c083fd651ede10f131bc1d6f5e462f23 SHA512 8e1f302d7e26d56edd924202435caef32369ea13eb4a0fdfb48c06bb5d77fd7a5aef92d470eef3e6fdd9c3b298751a52a83317e9ddf8b2aa7e3fedc75fb5151a
EBUILD pycodestyle-2.11.0.ebuild 827 BLAKE2B 25ba459cc2587c3bc37ffc426edb691e2e015e020909e3d283abeeeb9742d18908fe8a6543605e9ad706727df815083f00272f619c626ad42a49c76c6e98ffc6 SHA512 888081b6274506fec9db64ca4f6ebdcc9fc06d1cdb76dffa7509758d06f533454e7c0c1ba38d5aa396b6dca638f879032a5f25d92237697c63e7babdcf19860f
+EBUILD pycodestyle-2.11.1.ebuild 835 BLAKE2B 6f4b4d5a8275e554ec59079275b65d489cb88c6fbcb9fc8c960e6e014db66de2f87ca3de7acffef3d39a545188c8d44218e6e8b15fc53fdba10fdc91e1b865b8 SHA512 db32d903443cbf2ab4bfe0e77ee709821a7204acdba763afc4c3fa976ab049618d1a9e800bbeb0d60881e7cf825f3d58e4d18387e0faf465ced4e30b96b0f326
MISC metadata.xml 409 BLAKE2B 86d114cb53a68c8c24caebef1287bce1ae99cd652bca1fe2f19cce870c66490521329133a1fea47c79bd8c64d2bcd945022e31ac7db7885e9a4dea4d50f19a04 SHA512 e1de2014c44c8fdaf71ac26af406d27ab76cfd377dc20bb36e36bfbeab79f8e8981e8834e04b8e0bddd92d231b275e56e91d87570fee5ad426418a4abd00d4be
diff --git a/dev-python/pycodestyle/pycodestyle-2.11.1.ebuild b/dev-python/pycodestyle/pycodestyle-2.11.1.ebuild
new file mode 100644
index 000000000000..efb9462cf118
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+# 2.11.0 broke sdist
+# https://github.com/PyCQA/pycodestyle/issues/1183
+SRC_URI="
+ https://github.com/PyCQA/pycodestyle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest