summaryrefslogtreecommitdiff
path: root/dev-python/pyclipper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/pyclipper
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/pyclipper')
-rw-r--r--dev-python/pyclipper/Manifest3
-rw-r--r--dev-python/pyclipper/metadata.xml8
-rw-r--r--dev-python/pyclipper/pyclipper-1.1.0.ebuild28
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyclipper/Manifest b/dev-python/pyclipper/Manifest
new file mode 100644
index 000000000000..f4826b437172
--- /dev/null
+++ b/dev-python/pyclipper/Manifest
@@ -0,0 +1,3 @@
+DIST pyclipper-1.1.0.tar.gz 53916 BLAKE2B 53b7b6609d602cdcbd8c8f4ceaed999c97e155747f7daeb630333f18fd2719040d118c8fa3d0e60a1ccd92c20aecb355ec9d4f9c22f66dc07b14a919f981f667 SHA512 53371bc2e0439f72ac4ebf96f833c4451d2b1924d7f9cddcbac79a0a6d6bd95ac1fb3fb08e3ea3fcf3ffe22cd718d31c7c528016605b275a3e80642e58546d74
+EBUILD pyclipper-1.1.0.ebuild 696 BLAKE2B 743ad9c21a3bfb972f968f7ae226d3724ffa3d86a9e1afd4e2b2ed286ce726ae76d9121b104233254cd073647dbcfe6a42b9fdf76fa4081e1084cf941bfc3439 SHA512 5b6d3bbbd2e62f6c9f734f2638020634ca5dbc56673d59b1514a9a880423fca709b2844216c9bbab044865281232eb677dd7efd4e4bdb84d967760213d40d83c
+MISC metadata.xml 243 BLAKE2B f40c5d69470d5136cba32e1ea6b2351ca1842a5d83381e0bef3e063e266c64bebb9ba85e1f155010e219b136c2827c989d9adf3b2c6b2f6ca265f03339c9a7ce SHA512 640630eb9d42c319ca1da37b03a03677a3dd4e48f28ce2690b64f6e4e7d5885cfda41d439f3f9d8b009be04891b043a5b0ac6f9d43b701f65c8fcc0e0613b04a
diff --git a/dev-python/pyclipper/metadata.xml b/dev-python/pyclipper/metadata.xml
new file mode 100644
index 000000000000..3da97a9953cc
--- /dev/null
+++ b/dev-python/pyclipper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyclipper/pyclipper-1.1.0.ebuild b/dev-python/pyclipper/pyclipper-1.1.0.ebuild
new file mode 100644
index 000000000000..e639fa0cf58e
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}