summaryrefslogtreecommitdiff
path: root/dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild')
-rw-r--r--dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild b/dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild
new file mode 100644
index 000000000000..3352d3e25f64
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.3.0_p2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
+}