summaryrefslogtreecommitdiff
path: root/dev-python/pychroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-python/pychroot
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/Manifest4
-rw-r--r--dev-python/pychroot/pychroot-0.10.0.ebuild48
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild6
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 11863508dad9..84d8823d852c 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1,4 +1,6 @@
+DIST pychroot-0.10.0.tar.gz 23960 BLAKE2B 6d22ccbf3d71854d863577f0cf5ec3b1bea40f0f80d5c07942520d5d522ee299222e96cab4893c9cab93866c7f881052f67ad9091267c329a772fc4c3065bae1 SHA512 4a3941da9a94b75963e72536ec8f6218564dbdcb97e6314562044eb55f523e0704aecbc81e8e377338781e8bfd1a2aafb22cdc82f37bdb198a03e0e30d2323e5
DIST pychroot-0.9.18.tar.gz 32879 BLAKE2B 769b3347bae3f7dfb47c0335015cc898ec851a3d45f774a4e21aeaf9b8d7937331bc69aa5bcbb298e76e7e51ffc2e55f049336fd90f6b08fc3bba87089f2205d SHA512 59c8750c9ba8d601eca485079c04d4153bba92531dbd30fba0104694e4435d76e65b762b76ef89a6a6f8908dd6054d1d95fe4be74825ac1c5a56e473370dfa41
+EBUILD pychroot-0.10.0.ebuild 1103 BLAKE2B 3abfa08dc253404e555048e88c3b48bf30c6e332cebbe95605f4b53740ac35794c058d465336edfae0364419d32505958a32fceec355012000517cecb0af5c3b SHA512 29b6f7551ceaccfc18717ac4254088543176c81a2cac94e5d5b08484a257233e4fab0b8507e186f85db9478b55276f1068e86c9f2840f8c310210301b6e2b76b
EBUILD pychroot-0.9.18.ebuild 1142 BLAKE2B c8f1f4eb6f92378d0efc61c95d6e8e8bcaa1ffebe44db08d30b5552495f34ce84d4ce8e45ffcf753aac2f7cc01d26c763fc5cd829a7b53b65c322ccfc7958838 SHA512 be1db019faca07cefba2d1ef02b03792383ecd53ff9d1ced5e79151809bc6a60c258933718978b44f810cdde254be82d4c95c3c4b12e58249f05c3f9020326e3
-EBUILD pychroot-9999.ebuild 1075 BLAKE2B 99fd4195e1ab0e2804c64ccf69b19f32e34bcf0bb1ad86d4951529d597ac8b7f8c15c99e20f8a4837a44f3f5b298db5eb0ac49cacc67f798ea7b87b306157a4a SHA512 ace9b23a4ac509dcc3c9da7f2305ac71ce39eecba477a64e945a262259d1ec7ebe1346aa54604395a0b72573bfab5d84cafd63a458d6840235f4ad990c048e2a
+EBUILD pychroot-9999.ebuild 1103 BLAKE2B 3abfa08dc253404e555048e88c3b48bf30c6e332cebbe95605f4b53740ac35794c058d465336edfae0364419d32505958a32fceec355012000517cecb0af5c3b SHA512 29b6f7551ceaccfc18717ac4254088543176c81a2cac94e5d5b08484a257233e4fab0b8507e186f85db9478b55276f1068e86c9f2840f8c310210301b6e2b76b
MISC metadata.xml 337 BLAKE2B 3c60605dbe9296fe7f6c285123fa649b47c4997af6f715cefcb5047817ddff55f15c4813c2c33dcffa4e771ab3d0afb83bd88506d915e313b237e51ca4729c70 SHA512 4b0da70f35cd4983f6f5cd8aa02e5555b770d3bc2b7e90a8e8287c64593fadf1fe532cef6becce24de96766f94d24d8ec731ac3acff6f42a2c7b06c3e1e1e4d0
diff --git a/dev-python/pychroot/pychroot-0.10.0.ebuild b/dev-python/pychroot/pychroot-0.10.0.ebuild
new file mode 100644
index 000000000000..e1419b49ab2e
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ esetup.py install_man --mandir="${ED}/usr/share/man"
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index bda4fc26dfd5..e1419b49ab2e 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -19,16 +19,18 @@ HOMEPAGE="https://github.com/pkgcore/pychroot"
LICENSE="BSD"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
python_compile_all() {