summaryrefslogtreecommitdiff
path: root/dev-python/pychroot/pychroot-0.9.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pychroot/pychroot-0.9.18.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pychroot/pychroot-0.9.18.ebuild')
-rw-r--r--dev-python/pychroot/pychroot-0.9.18.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pychroot/pychroot-0.9.18.ebuild b/dev-python/pychroot/pychroot-0.9.18.ebuild
deleted file mode 100644
index 465cf543b277..000000000000
--- a/dev-python/pychroot/pychroot-0.9.18.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
- inherit git-r3
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="a python library and cli tool that simplify chroot handling"
-HOMEPAGE="https://github.com/pkgcore/pychroot"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-if [[ ${PV} == *9999 ]]; then
- RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND=">=dev-python/snakeoil-0.7.4[${PYTHON_USEDEP}]"
-fi
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- esetup.py build_man
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( NEWS.rst README.rst )
- distutils-r1_python_install install_man
- distutils-r1_python_install_all
-}