summaryrefslogtreecommitdiff
path: root/dev-python/pychromecast/pychromecast-9.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pychromecast/pychromecast-9.3.1.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pychromecast/pychromecast-9.3.1.ebuild')
-rw-r--r--dev-python/pychromecast/pychromecast-9.3.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pychromecast/pychromecast-9.3.1.ebuild b/dev-python/pychromecast/pychromecast-9.3.1.ebuild
new file mode 100644
index 000000000000..da95c8815f5d
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-9.3.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to talk to Google Chromecast"
+HOMEPAGE="https://github.com/home-assistant-libs/pychromecast"
+S="${WORKDIR}/PyChromecast-${PV}"
+SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]"