summaryrefslogtreecommitdiff
path: root/dev-python/pychm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pychm
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pychm')
-rw-r--r--dev-python/pychm/Manifest2
-rw-r--r--dev-python/pychm/pychm-0.8.6.ebuild12
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pychm/Manifest b/dev-python/pychm/Manifest
index 1517626194c1..9556bffcd63b 100644
--- a/dev-python/pychm/Manifest
+++ b/dev-python/pychm/Manifest
@@ -1,3 +1,3 @@
DIST pychm-0.8.6.gh.tar.gz 23803 BLAKE2B fdf3c37eead60455fd5bde1638a010f2788074752f98c32cf4b3431b4a87b8893c23a9fa29995352b35b41f628b7026fdbfa6ff20b75e8a6efdf75fc2da3f67d SHA512 cc1b254b6c58aba038171ad9db1eea3212094d7fb9386b22ada67381d702b388e6a1dde0317b5724587ee135d2695c546a7c2d65af7091dafeb394647597b0ae
-EBUILD pychm-0.8.6.ebuild 490 BLAKE2B f28c3f8e687a66a8dc46a544b18674a641c9dc0821c819c2266a0482e76e9c6b0a6044f4b24a5beeaae526c2c2205c2b78bb69548a1c3c8b445b1bd52e7cf658 SHA512 c3fda95a29c554b8936fd4866126c5e7d30b3bb22d66fd77f99ad991815c0a2cdcae0a4a18dfd87458d8f5c88fd905e41349c2c071f00f795e376ff869ae3f8e
+EBUILD pychm-0.8.6.ebuild 675 BLAKE2B c36fd039d5458d9ba27c1ca0f5aae2df7ff74bb2689b27957b62cfeb6993aa00b8019493ad139afb305b8461930df534374b02b879baf4328885f548547f98f3 SHA512 c3ce090e8e8c54cb1211db39e496d78e77cc13dc1d2f7e219a5f78f3760ae60fe5f04d630b88653206026b0a12dff644d12bf6da6d1af64b916549449c9cfa71
MISC metadata.xml 1024 BLAKE2B 4284f9d29a44bfb1997cc7e529bc28bef911febe769135b5837f5d81482d353e3377e162fa35f677a6ac1e29b1b467ee15caa1607ea789d3287d5a75f6db79a8 SHA512 f67597a0718d67bfc13216966d1a47f7192c17cbf939f10758c1ff09c761a07bfde094b1d4cf1c35acb872c6c6426cc1dc699a10f46448669ae645dd9f07507d
diff --git a/dev-python/pychm/pychm-0.8.6.ebuild b/dev-python/pychm/pychm-0.8.6.ebuild
index 90adc71074bd..3957210dc1f6 100644
--- a/dev-python/pychm/pychm-0.8.6.ebuild
+++ b/dev-python/pychm/pychm-0.8.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -19,3 +19,11 @@ RDEPEND="dev-libs/chmlib"
DEPEND="${RDEPEND}"
distutils_enable_tests pytest
+
+src_test() {
+ # need to avoid relative import of 'chm' directory but tests rely
+ # on locating files relatively via tests/...
+ mv tests .. || die
+ cd .. || die
+ distutils-r1_src_test
+}