summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
commit2e0bf408961ec1023d3db1fc5d687c233661ac26 (patch)
tree96c6e46af3c356d1fb470acdf72ada482bb293f8 /dev-python/pybind11
parent48dbe17904ac8ee6f006488d8f21734b0d253db4 (diff)
gentoo auto-resync : 17:03:2023 - 06:26:48
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest2
-rw-r--r--dev-python/pybind11/pybind11-2.10.4.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 98795534c2c5..84b29fc61c88 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,3 +1,5 @@
DIST pybind11-2.10.3.gh.tar.gz 740214 BLAKE2B 967b93cbf7d1f8faad25db9a4d3e84fd33b48429cdf527c167e65faad5c01df83a5634021cf99f07adf443855d9f6bb076f0cc67b0e6555e189b794a845b533a SHA512 3894400f04cd08e2dbb14b3d696339f0364434f1d6f8bb057338ac88157ec7491b2df1e1e46ebd5abccdcd5775c5e9238de6404f0db87f64f5a1802db3a5b18c
+DIST pybind11-2.10.4.gh.tar.gz 740622 BLAKE2B 7b2d86e8262581b2cc6dd720b83336206e242ef8ca99b257b01a11141ed8b127d7f35d7d573bc763dd36f2fe8c8ac91766089deb63a76e9c10029c34eec2d6d3 SHA512 7970defbb6d057a44468ed707c80bfa6ef8c9578528fbc084b03aeea20a52dbd681581f82d55ff90af11ee89693379bd79e2ab6603239ba05b0aa8da29dd93c7
EBUILD pybind11-2.10.3.ebuild 1237 BLAKE2B 17590abe071c68edf93fb630c7e10c770edae992d1bac7177c4b5258a55db4f0371f518c021ad383b21d9becace91bfb288dfbd0cb60fc40ae2ea8ca22ed7b2a SHA512 47664fc3cae4088de5228e08f39c87df059f85f9f0651d4db726cc49bce961a3c44f1b3d57531b9964489c0cdfdd4d94fa1aeea1893e759438c132e814ebda9f
+EBUILD pybind11-2.10.4.ebuild 1288 BLAKE2B 2d4c4f2e46e1524705c8ed249bed0fab8c618c7839df234bc6a58db89ceeb2a45aa90ca3cc6a446427a4042dfdf29633392639872056705b4606b7335d031cdd SHA512 24f565a85c013a920ba3232e5cdb20ed86c6489ab101cf681c5d7833ec1c6211c754da2ac32f1e047e381d8a2e0e738697cb1a5f4206c63dcc2f3267d6b8638d
MISC metadata.xml 475 BLAKE2B faf317a1197850acb0d16546a303bd50ee1bfe6fc3aaf592e6c147c6612fd20b809f1c911d79ca9a356cfa0c4166d2b155fcbd593f8b55e0d7dd75ff6444073b SHA512 5779adcc9f25c15fd999aa6c91d3144fc14535270e57925bfb8ac67f45448c144a142af2ea9a321ec6ffbf568713f663cef85a0be3d4a056e58b1782a5fc9a41
diff --git a/dev-python/pybind11/pybind11-2.10.4.ebuild b/dev-python/pybind11/pybind11-2.10.4.ebuild
new file mode 100644
index 000000000000..79dfba9034e7
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.10.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="
+ https://pybind11.readthedocs.io/en/stable/
+ https://github.com/pybind/pybind11/
+ https://pypi.org/project/pybind11/
+"
+SRC_URI="
+ https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+BDEPEND="
+ test? (
+ >=dev-cpp/catch-2.13.5
+ dev-libs/boost
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}