summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/pybind11
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest2
-rw-r--r--dev-python/pybind11/pybind11-2.9.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 1a2cba1fd262..45481d3bd2d4 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,3 +1,5 @@
DIST pybind11-2.8.1.tar.gz 693075 BLAKE2B 00f691121858bbe019b5398ab5418523b352f29716901ec6572817e3a35efeb953a9a1542ad37830aab6b9e5a6d6dd56c7aee390772f1d992ef570e03472ebd8 SHA512 6738b4551a1ca2fdf6676be78216b9056cecf8b4d125f0d1aaae9929614bcbf4a9b233fc3c52b8f9dfd19a9ca1496515e6748c1afd8968b9c52c9a1e8b28da10
+DIST pybind11-2.9.0.tar.gz 698784 BLAKE2B bfbe173d580131e445d759bd9b1a8929ceb9fc357a1ed8873aa8024fb9226a37bb97293dc0189a67ae61a232f3790ca6f635a30d0a0401c867cde98f1010438c SHA512 87184c9e09e1340f2d34786a66560fe77684a3629b517f78321073a1f0dfdb766365d3698dcf6f08e5141b1f4da50ec917e61b36538e5a1ec9fd1b68f29cd396
EBUILD pybind11-2.8.1.ebuild 1072 BLAKE2B a168784e70bf21188a8a0180a5db73fc6e2e4b392b16d0172e50fa67dbb486a7e7d4d1d1e7afcae7e79bff5ac4d877c7249f2bdb5b809effe9e1727f0056abb3 SHA512 be3d0bd87ef1d8df6f008356246f45e71537960491e347c3cdf0e1ed21abc25139e3b6540334012d0e7eb69856349bff08b4520f8fa42d2224cdf4dd7b61635f
+EBUILD pybind11-2.9.0.ebuild 1078 BLAKE2B a875df1d0efd27240980855acc42ee2026ac0ef0328256ac805b6bf05723975c4b401c11c6788d93f52c666ceb5c7ac8fcd53e55992e43cf8d3e0851773fab26 SHA512 08b0413dd0db90deeb790e45fcf429c981894fd9f0c2124fb419fe4e9b1c675a96429a0d0bde78b0d7331f2d111c66efbd349d7cbedf36e358e52582a4de04e2
MISC metadata.xml 420 BLAKE2B 8a3480ac275b7e2893d696bf4fd0d70f41ea941fab9e24b19d8561c0efeee81024ba6fea0ab26333346f3c176d1a87b35229e31ecefc74de2e7614600a64013e SHA512 8140e933878a75968420deab189bab1decd030b5209baada2857a7659dc32980bbc46678c6612ef56e4b4f6b598579bb8227e6c7fd00fbde63a40eb13bccf86c
diff --git a/dev-python/pybind11/pybind11-2.9.0.ebuild b/dev-python/pybind11/pybind11-2.9.0.ebuild
new file mode 100644
index 000000000000..54e1aa92dba5
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}