summaryrefslogtreecommitdiff
path: root/dev-python/pyatspi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyatspi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest4
-rw-r--r--dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch26
-rw-r--r--dev-python/pyatspi/metadata.xml8
-rw-r--r--dev-python/pyatspi/pyatspi-2.24.0.ebuild57
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
new file mode 100644
index 000000000000..98c9a4efe89f
--- /dev/null
+++ b/dev-python/pyatspi/Manifest
@@ -0,0 +1,4 @@
+AUX pyatspi-2.6.0-examples-python3.patch 791 BLAKE2B ad8130ef64605915b3124dd268bb002e8e4a32c7c3e3e7f4445a5ee7e6a899b1caae25e1ecaff417d2d121063361d3dd983df08bafa666ab03aa6746fa21151c SHA512 7171f77080fed4ef235d1d3380821939d5a41e919b8509db8dcbe211d63b7b390e66389152c7275128cc8372c2a7fd1bdfaf179fc93b8fa62ed76a6edffd11ed
+DIST pyatspi-2.24.0.tar.xz 298228 BLAKE2B a1c989df5431a9fdf0b35c5fa75a12b9c083c6a979052e3a621685feada611f4322195b30bc1f4f56cd35f305087756cded31a445cca07e74262ecd807926239 SHA512 ea0c3e5a5a417c4d494cfe33ccfcca1996f417e51f5ccd3508372a0df636fb186b9940d7832681af9b353aa50a9aabd64c5477fdabbc5016794a502396b3d67a
+EBUILD pyatspi-2.24.0.ebuild 1297 BLAKE2B 232974954d137d16728d738e2ed0e4f3c206ba1c608a1e5997e9868f02a4cc6e9d825480bec8b1d3af7a9961a101f2e2514eb51ed5687dfae3369ca11a94ed5e SHA512 07a7cba527f24318267f80964953cdf5201a202db70dc096e117249cdb562a64e854056c90915ba473867443c7e94931834217c7f0fc7d21608da8cfa56ef15d
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
new file mode 100644
index 000000000000..423cd644073c
--- /dev/null
+++ b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
@@ -0,0 +1,26 @@
+From 4f10a696002179082e41568b5109400ac8478a96 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 10 Dec 2012 04:52:03 -0500
+Subject: [PATCH] examples: support python2 and python3 syntax
+
+https://bugzilla.gnome.org/show_bug.cgi?id=689957
+---
+ examples/magFocusTracker.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/magFocusTracker.py b/examples/magFocusTracker.py
+index 47efe00..7ca3b67 100755
+--- a/examples/magFocusTracker.py
++++ b/examples/magFocusTracker.py
+@@ -282,7 +282,7 @@ def main():
+ startTracking()
+ pyatspi.Registry.start()
+ else:
+- print 'Magnification service not available. Exiting.'
++ print('Magnification service not available. Exiting.')
+
+ return 0
+
+--
+1.8.0
+
diff --git a/dev-python/pyatspi/metadata.xml b/dev-python/pyatspi/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-python/pyatspi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyatspi/pyatspi-2.24.0.ebuild b/dev-python/pyatspi/pyatspi-2.24.0.ebuild
new file mode 100644
index 000000000000..347a19895d37
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.24.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 sparc x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.20.2[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+)
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ docinto examples
+ dodoc examples/*.py
+}