summaryrefslogtreecommitdiff
path: root/dev-python/pyatspi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/pyatspi
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest2
-rw-r--r--dev-python/pyatspi/pyatspi-2.38.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index 894219875575..cb2e40aea934 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,3 +1,5 @@
DIST pyatspi-2.38.1.tar.xz 316724 BLAKE2B 59ca2569575f3d319d33972477ebc966670138df8cb6570ac260dd903f54df66fd12beeeee53e3380938e4571910b99ae2bf3f395776b16a73ac27f8fa023c49 SHA512 bf8f1ee9a6e00014a84e4329bb971bec8b4bc8f72c3905ca585ca20b1cf000b855965159fcc10871eb92e9808a6b41b5d793f3ab563ff0867f185279eedcd487
+DIST pyatspi-2.38.2.tar.xz 318596 BLAKE2B aba5d4fbbc9e0ce4793843270394712e675e6546c781f0523f7f17a79f018fcf4cf209257e9ef0dc03cbe92be7a17c774fd82f2d9997d9aa8c6b6be65a72ef8a SHA512 03e10af5f0eb2ab89518229f049f497635ec1ae85a948a02813a5eb00eef395a3934f578b56054f8e73ae3c5c28760ad1f2b93e8876b8724c64b622d966aa5d9
EBUILD pyatspi-2.38.1.ebuild 1308 BLAKE2B 3ba8aced6adce9eccef590c6714316901f5ae6ed8ed4f38360c6759a82919c1b975607456255230af803a1ee0f93db7598a3004c56e86ca7375e42810702b1c4 SHA512 ec8592a592b2e7a23ad69e0841a36805fe4a179645f16e22b41c0c60360699caa0ca8be614c390fbf3b2ecb5275866297aa08520f018b2fd8a040a3234c6acb8
+EBUILD pyatspi-2.38.2.ebuild 1312 BLAKE2B 6a6d13a9f60299610436df8d0fd5328c7712c1d512eddb95038ed318ab4e46d9dd7f37d6eac80b1ffa303221a7666374c14c4c549f71ba81c8f27c0a3ca1f788 SHA512 593ca00295bfd7308110d2dd7c631f31f21069663e5f46de410362ff0b4e8dca8899af5fd0517714a0b83e7edd31413319db7eda2af32544ec5c69a9a2da0017
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/dev-python/pyatspi/pyatspi-2.38.2.ebuild b/dev-python/pyatspi/pyatspi-2.38.2.ebuild
new file mode 100644
index 000000000000..fb04dba8dd7e
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.38.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome2 python-r1 virtualx
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+"
+BDEPEND="virtual/pkgconfig
+ test? ( x11-libs/gtk+:3 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure $(use_enable test tests)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir virtx dbus-run-session emake check
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}