summaryrefslogtreecommitdiff
path: root/dev-python/pyaml/pyaml-23.5.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
commit02930d1eb5af78d32b1597af6af24163895d9e0f (patch)
tree7908188ca5a80d7ff557ebc70fe3bdcbf2875832 /dev-python/pyaml/pyaml-23.5.9.ebuild
parent54654470d999265b5a0010be7190e8a9993b1840 (diff)
gentoo auto-resync : 11:05:2023 - 23:47:37
Diffstat (limited to 'dev-python/pyaml/pyaml-23.5.9.ebuild')
-rw-r--r--dev-python/pyaml/pyaml-23.5.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyaml/pyaml-23.5.9.ebuild b/dev-python/pyaml/pyaml-23.5.9.ebuild
new file mode 100644
index 000000000000..cf3738ac27a8
--- /dev/null
+++ b/dev-python/pyaml/pyaml-23.5.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="
+ https://github.com/mk-fg/pretty-yaml/
+ https://pypi.org/project/pyaml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest