summaryrefslogtreecommitdiff
path: root/dev-python/pyamg/pyamg-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /dev-python/pyamg/pyamg-5.0.0.ebuild
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'dev-python/pyamg/pyamg-5.0.0.ebuild')
-rw-r--r--dev-python/pyamg/pyamg-5.0.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyamg/pyamg-5.0.0.ebuild b/dev-python/pyamg/pyamg-5.0.0.ebuild
new file mode 100644
index 000000000000..4171b0ddd8fe
--- /dev/null
+++ b/dev-python/pyamg/pyamg-5.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="
+ https://www.pyamg.org/
+ https://github.com/pyamg/pyamg/
+ https://pypi.org/project/pyamg/
+"
+SRC_URI="
+ https://github.com/pyamg/pyamg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/CppHeaderParser[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs pyamg
+}