summaryrefslogtreecommitdiff
path: root/dev-python/pyalsa/pyalsa-1.2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /dev-python/pyalsa/pyalsa-1.2.7.ebuild
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'dev-python/pyalsa/pyalsa-1.2.7.ebuild')
-rw-r--r--dev-python/pyalsa/pyalsa-1.2.7.ebuild27
1 files changed, 23 insertions, 4 deletions
diff --git a/dev-python/pyalsa/pyalsa-1.2.7.ebuild b/dev-python/pyalsa/pyalsa-1.2.7.ebuild
index 9d79adb5891d..3840bf92b6eb 100644
--- a/dev-python/pyalsa/pyalsa-1.2.7.ebuild
+++ b/dev-python/pyalsa/pyalsa-1.2.7.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 flag-o-matic
+inherit distutils-r1
DESCRIPTION="Python bindings for ALSA library"
HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
@@ -14,7 +14,8 @@ SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE=""
+# Needs access to system's alsa configuration/devices
+RESTRICT="test"
RDEPEND="media-libs/alsa-lib"
DEPEND="${RDEPEND}
@@ -22,4 +23,22 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch" )
-# Testsuite appears to require installed state
+python_test() {
+ cd "${T}" || die
+
+ shopt -s nullglob
+ local test
+ local failed
+ for test in "${S}"/test/*.py ; do
+ ${EPYTHON} "${test}" || {
+ eerror "${test} failed with ${EPYTHON}"
+ failed=1
+ break
+ }
+ done
+ shopt -u nullglob
+
+ if [[ ${failed} -eq 1 ]] ; then
+ die "${test} failed with ${EPYTHON}"
+ fi
+}