summaryrefslogtreecommitdiff
path: root/dev-python/pyaes/pyaes-1.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pyaes/pyaes-1.6.1-r2.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pyaes/pyaes-1.6.1-r2.ebuild')
-rw-r--r--dev-python/pyaes/pyaes-1.6.1-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyaes/pyaes-1.6.1-r2.ebuild b/dev-python/pyaes/pyaes-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..d69eebe72764
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.org/project/pyaes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pycryptodome[${PYTHON_USEDEP}] )"
+
+python_test() {
+ local t fail=
+ for t in tests/test-*.py; do
+ einfo "${t}"
+ "${EPYTHON}" "${t}" || fail=1
+ done
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}