summaryrefslogtreecommitdiff
path: root/dev-python/pyacoustid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 04:43:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 04:43:25 +0100
commit7bb2a634b4e693c8545db3823c080e6edec25e77 (patch)
tree292ea8f5cd2042167674fa08e993aefc95f062d5 /dev-python/pyacoustid
parentd24a417ad25a06bbd0cb13469ec2278ae8f33fba (diff)
gentoo auto-resync : 13:09:2023 - 04:43:25
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/Manifest2
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.3.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/Manifest b/dev-python/pyacoustid/Manifest
index ce424b2a45d3..857040cd9c02 100644
--- a/dev-python/pyacoustid/Manifest
+++ b/dev-python/pyacoustid/Manifest
@@ -1,4 +1,6 @@
DIST pyacoustid-1.2.2.tar.gz 15869 BLAKE2B 01f327dd640819dd799f48b32e859fe39dccda3fd62714bf324c8219cf7053b36f1399793523634e9d4f3c6405bed5050abb34bdf53c72ff0ee22708fb57225a SHA512 5bcb3f017c3013eb8fc9e335540a1f5e6a52fc2fefa53d5ef246ba16e4ff615dd1d1cf08b5c80b1a38b149e0fa7dc0b15e4890dcc3f5478ef874b4ec22cf0813
+DIST pyacoustid-1.3.0.tar.gz 17369 BLAKE2B 93f949943d792b4c1f4b2b99ae37821c1ffa5c7a2bbeda7aed276e6ad4f9ad35e5fc4c6e590667bee552710eec483cf2a16f58a7f34a1f02c94b4cb84ec45cf4 SHA512 3b38e580b2deda30df683fe749b338929be0ca23fb3ff462a5df9b98f140db4bde682d74254e7f3a157e394e824ecb6929171392b5e6c9bd92ca05fb6f71ed0a
DIST pyacoustid-test.mp3 4507187 BLAKE2B 54494d9f23481f9d1ee77b136ac3e1790e9fb78c782159ad1793dbebf18f694e13f6413a8259bae84c789f73ea8241e590dbd7e30ccb7377b2afa946335da19b SHA512 faa582640e759322d4bd58d85f4aa7d3ef88fd90aa3c67c1390ba6d4c3213278c11fb60c8d6c87a25e82dffcc54986caa4f0e463acfbcd90993166577e5226d8
EBUILD pyacoustid-1.2.2-r1.ebuild 1149 BLAKE2B 09f5948ae64233305d947149c70b8f1304d0e89a3be60b67ae86e51bb8d74c12b3971f299b1f7ce99e8532502d3700e322f741cd5ccc92d2bdea8b4af4d60e5d SHA512 0d0f9334ad2a4544d868888c3fe0ff2797eb2bb45474692719775d56f8c3fa31c4e052698cb01203a69b444c20cce41b5a678f08f454c384e3a289107ca91292
+EBUILD pyacoustid-1.3.0.ebuild 1173 BLAKE2B 60e6bfe55c4eb2588907b7eef4318476f3fec61897e5e63880fa434bd365990ff19bd603dbc12b5e085b85e345e5133537bef1243934c89d17ed97c97dfbfb17 SHA512 00e93914a6731cf10850c5ed690e4366dc7830ee7debbadb075dbc2ea8abd02dae266f986cb0326c396b2052b1735a73eaf84f4317be6941e4acae2129fa1061
MISC metadata.xml 714 BLAKE2B bc0db30cff6644da34b7944bec3d60b47f394ac854d547fcbbf3ee4d2719edc4cb781a42b3ab266fb7dfb5762679daaa0e382fd0fa8c2cffdd35af4cc55633be SHA512 6b6063bfe7d64d8a053c0e5c1609d8011e8aeeb265a895db88154e246761027ec2ba5fd582fb08b64e5ee09b3a238030415613df9267620936a718b76d6d1692
diff --git a/dev-python/pyacoustid/pyacoustid-1.3.0.ebuild b/dev-python/pyacoustid/pyacoustid-1.3.0.ebuild
new file mode 100644
index 000000000000..168c291cc74a
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="
+ https://github.com/beetbox/pyacoustid/
+ https://pypi.org/project/pyacoustid/
+"
+SRC_URI+="
+ test? (
+ https://s3.wasabisys.com/blocsonic/releases/maxblocs/bsmx0198/01-Follow_192kb.mp3
+ -> ${PN}-test.mp3
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+# Tests fail with network-sandbox, since they need to connect to acoustid.org
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/audioread[${PYTHON_USEDEP},ffmpeg]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/chromaprint
+"
+
+python_test() {
+ # Working test will print the top metadata match from Acoustid's database.
+ "${EPYTHON}" aidmatch.py "${DISTDIR}/${PN}-test.mp3" ||
+ die "Test failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc aidmatch.py fpcalc.py
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+}