summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pyGPG
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pyGPG')
-rw-r--r--dev-python/pyGPG/Manifest3
-rw-r--r--dev-python/pyGPG/pyGPG-0.2-r1.ebuild44
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild25
3 files changed, 58 insertions, 14 deletions
diff --git a/dev-python/pyGPG/Manifest b/dev-python/pyGPG/Manifest
index a038f580741b..c889f83166f8 100644
--- a/dev-python/pyGPG/Manifest
+++ b/dev-python/pyGPG/Manifest
@@ -1,4 +1,5 @@
DIST pyGPG-0.2.tar.gz 15439 BLAKE2B 92c82b8b23c279461a872f118c636fa9cdae3f44910fc34a357983b0b4afea2a7b13c6400499a0fdbb4365357ade64294642178ca07a79ab3b7df89e60146e73 SHA512 93d892a57a27b254bfdc9778b73d341dfec654c2104c578014628df78c43beaf93eafb571ac544d52f334e63f6e5b8c0cfad7c8a0d585ee7211e8649efce8c67
+EBUILD pyGPG-0.2-r1.ebuild 1158 BLAKE2B a03278ad31f9e185d728b52fc538a28b098c4cc3a619ed523a44a51315334c8c745938bf9ad8afff1e7992c3ce73b86548ef027e73f9a43d44cf034e8c92b554 SHA512 53f1116af1a8cbcf1996e0aae1b157f0f7a8e0f4c359435553bbf9368d50b6ebbcc2ea326d06c07d8c2b9d122a8aede45068f0f3f6077a4b0142b569d284f7d7
EBUILD pyGPG-0.2.ebuild 1157 BLAKE2B a4b93515073eb71c7dee0e0ea1dadf627329e1b9f4e2d423c144c42cc91821a551cdbbd825d0411e3da86d25b1a086af14d0bde8f38f88f9086aeafd83bd9952 SHA512 5b1ded477bb7239380706db2581af68985ed9494d76f68c33592663cd8e95cb925c99c7497a884f0ef21f25e246158842787e89ea8e3642742255b8db167f93c
-EBUILD pyGPG-9999.ebuild 1164 BLAKE2B 4f2a482f36fe90b9f4d87a054b2d187c0d4f7a6d15838de092e8edf31a560b4d436c476789bfc1913adb3da1542c6d9e2fb4211fd1d00c9599cb885191c9bbfc SHA512 8b23a0c9b7a5fc82b62e5452c365c2c5aaa506c192b830c46a42d5be25b8f226ec43d16e3d089c7f1ae927815a20d67871bc1a6124c8a88c265b3582cff331f2
+EBUILD pyGPG-9999.ebuild 1158 BLAKE2B a03278ad31f9e185d728b52fc538a28b098c4cc3a619ed523a44a51315334c8c745938bf9ad8afff1e7992c3ce73b86548ef027e73f9a43d44cf034e8c92b554 SHA512 53f1116af1a8cbcf1996e0aae1b157f0f7a8e0f4c359435553bbf9368d50b6ebbcc2ea326d06c07d8c2b9d122a8aede45068f0f3f6077a4b0142b569d284f7d7
MISC metadata.xml 567 BLAKE2B e0c99fa711e08f9ae227c71f685083871aed97c2b8e07ea67e02bd9685f0b1c05a7cb5cca4b9b7405b3c6af49659bb7d79bad1128a3696d7b918c9ff93ccd13a SHA512 ce22011a182f373d6507ddc8eb2658d0f0e74e5f2d281a6dc4326b5c04a34320ccb294c4606da641c1a24d0563a612931cb4a1acdda61db02a723b4111d89b77
diff --git a/dev-python/pyGPG/pyGPG-0.2-r1.ebuild b/dev-python/pyGPG/pyGPG-0.2-r1.ebuild
new file mode 100644
index 000000000000..1649f810972a
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ elog
+ elog "This is experimental software."
+ elog "The API's it installs should be considered unstable"
+ elog "and are subject to change."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/pyGPG/issues"
+ elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+ elog
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
index fc4ad1900dce..1649f810972a 100644
--- a/dev-python/pyGPG/pyGPG-9999.ebuild
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=no
-
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
@@ -31,15 +30,15 @@ RDEPEND="${DEPEND}
"
pkg_postinst() {
- einfo
- einfo "This is experimental software."
- einfo "The API's it installs should be considered unstable"
- einfo "and are subject to change."
- einfo
- einfo "Please file any enhancement requests, or bugs"
- einfo "at https://github.com/dol-sen/pyGPG/issues"
- einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- einfo
+ elog
+ elog "This is experimental software."
+ elog "The API's it installs should be considered unstable"
+ elog "and are subject to change."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/pyGPG/issues"
+ elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+ elog
ewarn "There may be some python 3 compatibility issues still."
ewarn "Please help debug/fix/report them in github or bugzilla."
}