summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG/pyGPG-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pyGPG/pyGPG-9999.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pyGPG/pyGPG-9999.ebuild')
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
index fc4ad1900dce..1649f810972a 100644
--- a/dev-python/pyGPG/pyGPG-9999.ebuild
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=no
-
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
@@ -31,15 +30,15 @@ RDEPEND="${DEPEND}
"
pkg_postinst() {
- einfo
- einfo "This is experimental software."
- einfo "The API's it installs should be considered unstable"
- einfo "and are subject to change."
- einfo
- einfo "Please file any enhancement requests, or bugs"
- einfo "at https://github.com/dol-sen/pyGPG/issues"
- einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- einfo
+ elog
+ elog "This is experimental software."
+ elog "The API's it installs should be considered unstable"
+ elog "and are subject to change."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/pyGPG/issues"
+ elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+ elog
ewarn "There may be some python 3 compatibility issues still."
ewarn "Please help debug/fix/report them in github or bugzilla."
}