summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild')
-rw-r--r--dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild b/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild
new file mode 100644
index 000000000000..6749e63d1904
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2_p20220808.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+ EGIT_BRANCH="master"
+elif [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="eb44ec69978044809325a0a9c8972d1d4f573b47"
+ SRC_URI="https://github.com/dol-sen/pyGPG/archive/${MY_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+fi
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+
+LICENSE="BSD"
+SLOT="0"
+if [[ ${PV} != *9999 ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+RDEPEND="app-crypt/gnupg"
+
+EPYTEST_DESELECT=(
+ # Expired keys
+ test/pyGPG/test_gpg.py::test_listkeys2
+ test/pyGPG/test_gpg.py::test_listkey2
+ test/pyGPG/test_gpg.py::test_listkey
+ test/pyGPG/test_gpg.py::test_fingerprint2
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "This is experimental software."
+ elog "The APIs it installs should be considered unstable"
+ elog "and are subject to change."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/pyGPG/issues"
+ elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+ elog
+ ewarn "There may be some Python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}