summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG/pyGPG-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyGPG/pyGPG-0.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyGPG/pyGPG-0.2.ebuild')
-rw-r--r--dev-python/pyGPG/pyGPG-0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyGPG/pyGPG-0.2.ebuild b/dev-python/pyGPG/pyGPG-0.2.ebuild
new file mode 100644
index 000000000000..46854436ed53
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}